Happy Easter! Bubble is broken? bug demo attached

This problem appeared for me late friday. Around that time, other users reported bizarre behavior on the forum too. I developed my app for weeks, tested with hundreds of messages, did not encounter this problem until friday night. So I created a demo/video to illustrate:

The bug: workflow with “pause” + “create a thing” causes app to break.

The demo: a simple repeating group, two buttons, one to add an entry (create a thing), one to add an entry with a pause beforehand to display a banner, then create a thing.

The workflow with no pause works flawlessly, I can add as many entries as I want. The workflow with the pause causes the app to crash after adding 15-25 entries.

I replicated on Win10 with firefox, chrome, and opera; MacOS chrome, safari; iPad/iOS Safari, Firefox.

Do you see the same bug with this simple demo/video? Please post a reply if so.
Watching the network tab in your browser’s developers tools more clearly shows the app spinning out of control. (I will try to withhold my rant until others verify…)




I have not been able to replicate the issue on my iPhone in safari. :confused: Sorry. I tried.

Maybe the app is hitting a capacity limit?

First of all, thanks for trying.

I obviously didn’t consider mobile layout in my demo!

Interestingly when I used iPhone user-agent in developer console I did not immediately see the bug.

Also did not consider capacity limit, so I will look into that (demo is a free app with no data/objects/workflows, but then again I have no idea how capacity works!)

Thanks for your help!

Correction: forgot to constrain the search to “current user’s messages” so the demo wasn’t working properly, it was showing everyone’s messages rather than just your messages. That is fixed. Now re-testing for the bug…

No offence, but no one is going to click a button that many times, if you want, you can make the button non-clickable and then show a loading icon, but I don’t really think this is a bug.

This is a messaging app. After user sends 15-25 messages, the app crashes. Even in this stripped down demo…

After the send message is clicked, make the button non-clickable and show a loading icon.

Thanks for your input @marcusandrews, I forgot to add “No offense taken!” to my last post.

So the issue appears to be that any workflow that has a pause along with a create a thing causes this crash…and that just started happening last night.

The pause/banner in the demo is just to illustrate that the workflow is executing the pause (while the banner is visible). It could be an icon instead.

I’d clarify that I’m not testing if the button is clicked again during the pause, it just takes a 1000ms wait (also shown by the progress bar) then the message appears in the repeating group, ie, the thing was created and is now in the message list. Then repeat 15-25 more times.

I’ve worked on my app for weeks and added hundreds of messages with no problem using workflows that had pauses, until this started last night.

So i created the demo to remove all my app features, addins, elements, workflows, etc to try to get to the bottom of it. The demo is intended to show that simply adding a pause in a very simple/identical workflow causes bubble to hang.

I do appreciate you looking at it. Were you able to replicate?

I’ve also replicated on ipad/iOS 12.2 safari and firefox, different wifi network, which prior to last night also worked fine. Working on figuring out how to post a video…

To rule out repeated button clicking while the workflow is still running, I set the demo to hide the “add message with pause” button while the workflow is running. I’m still getting the crash.

Record your screen and post the video. Point out exactly what happens and what we should be looking for. I know it’s frustrating to have a bug and no one else can see it. Also try resetting your cookies in your browser. That might help with testing to see if it’s just something with the browser.

Hope you can catch it in a video for us. :slight_smile:

Thanks, I added the video. I flushed all browsers caches, rebooted, even installed chrome just to test this!, ran in incognito, etc.

In the video, I show what I tried to describe above. I load the page, open the developer’s console, then add about 40 messages using the “no pause” button, works fine. Then I refreshed browser, then added 15 messages using the “add message with pause” button, and bubble crashes–sending about 100 post api’s about every 2-3 seconds until I force it to stop by pressing the delete button.

It’s my first video so sorry if its not precise!

(thanks again for helping!)

Have you tried turning off your VPN too?

Anyways, I would file a bug report and send them the video to look at as well. Hope they can fix it for you.

Yes, replicated with VPN off too. I think there were some bubble changes yesterday.

I filed the bug report immediately: got the canned reply reminding that “support is during weekday business hours…” Thanks for that.

Turns out that if you let the AJAX error run wild, after about 900 fails


or 120 secs, it finally spits out an error to the console.

Seems a bit sloppy to allow that much time to figure out that there might be an error.

This topic was automatically closed after 14 days. New replies are no longer allowed.