[Help Please] Rich Text Input has no Dark Mode

I have a black background and a Rich Text Input on top. I need the blinking typing cursor to blink a light colour, not black, the placeholder to be light, not black and when a user starts typing, it’s in black… on a black background… with no way of changing it that I can see.

Every rich text editor on here is basically light mode, does anybody have any workarounds or know of any other plugins that doesn’t have this issue? Or a way of making this plugin (the free Rich Text Input from Bubble) work for my use case? I’ve checked all the others and they all seem to be the same.

Thanks,

Ash :bearded_person:t4:

Settings tab -> SEO -> page header code

Use custom CSS to design a dark mode.

Probably you’re only work around unless a plugin offers dark mode.

Wouldn’t know where to start with CSS :pensive:

Screenshot 2020-12-11 120441 Screenshot 2020-12-11 120417

In settings set text to white, border to desired color.

Find the class that is needed to change just the background color of the editor box and turn it the same as your background color on app using CSS

Also change the icons to white using CSS

Thank you so much Chris, I figured it out from what you said and a little common sense.

For anybody else that has this issue or needs CSS to bridge the gap:-

  • Click SETTINGS
  • Click SEO/meta tags
  • Scroll down to Script / meta tags in header
  • Then go to the Design (your editor) and choose an element you wish to change, right click it on Chrome and choose Inspect Element
    Note: you may need to inspect it again once the editor is open.
  • On the side you have styles, click around until you’ve changed what you’d like.
  • In the styles section that you’ve just changed, grab it from the brackets } and {.
  • Copy and paste it into the Script / meta tags in header
  • Put a at the beginning and at the end.

You’re done :slight_smile:

Ash :bearded_person:t4:

2 Likes

This topic was automatically closed after 70 days. New replies are no longer allowed.