Help - recursive workflow not running / JSON formatting weird

EDIT: Updated this from Need Help to Bug.

This was running perfectly a few hours ago and now it breaks. I’ve reverted to the previous Save Point but still not working.

I’m sending JSON from the front end to the backend via an API connector and running a recursive workflow on it. Two issues I’m seeing:
A) JSON is formatted oddly when I’m processing it in the backend workflow (may have been formatted like this when it was running but I can’t remember)
B) Backend workflow where I run the recursive workflow isn’t event starting.

As mentioned, this was working great a few hours ago, was just playing around with some front end stuff. Unsure where I messed it up.

  1. Get JSON and send to Backend Workflow ‘csv_upload_add_product_pricing’ via API connector called ‘Add Pricing (live)’. - This seems to be working ok.
    |
  2. Take all the JSON, split it out into it’s component parts from the API connector and schedule a new backend workflow ‘csv_upload_add_pricing’. This is where the formatting looks weird (see point A above)


|
3) Run a recursive workflow ‘csv_upload_add_pricing’. This workflow never starts.

There are a couple of observations around workflows. What is the status on your observation? Is it still not working?

Simple fix. I had forgotten to restart the scheduler

1 Like

me too! I haven’t used this button before - had no idea obviously of the impact.
Not very clear in the logs either. But anyway - thanks

1 Like

This topic was automatically closed after 70 days. New replies are no longer allowed.