Hi, anyone can help me with this? I'm having a hard time to figure out this problem

As the error says, scheduling background workflows is only on the paid plans. Free plan doesn’t have it. (It only has 2 weeks trial).

But I’m still in the 4th day of this trial.

Are you sure Backend workflow is activated?

Check Settings - API - “Enable workflow api and backend workflows”