How to apply Space around container alignment option to repeating group

Hello, bubblers!
I faced a challenge with aligning content within the repeating group in the new responsive engine.
I have a container with a maximum width (1440 px in my case).

This means I want the content of my page not to cross this border and be distributed between the left and right corners. The Space around option works perfectly for general row containers.
But with the repeating group, this trick doesn’t work.
I found that if I set the container alignment option to Space around value to the repeating group, content within cells align to the left side of the cell. And this is happening in all the cells. So the expectation was content will be distributed from the left to right corner of the repeating group container width. But it doesn’t happen.

I tried different options of appearance settings, for example, Stretch columns to fill horizontal space, but it doesn’t work.

Can you please help with finding a solution for the case?

Repeating groups are often on their own trip :grinning_face_with_smiling_eyes:
I wish there was a way to do what you’re saying with a variable number of rows and columns.

I do think there should be a way to achieve this by setting a fixed number of columns and then stretch columns to fill horizontal space.

All the best

1 Like

Thank you for your reply!
I feel your pain man. :sweat_smile:
Well, columns overlap when a number of them are fixed, unfortunately. So this is not responsive behavior.

That seems to be a min width issue
Try making it 0?

Nope, it already set

@preencipium probably bcs you have the RG still set to “3 columns”. Try making it 1 column when the current page width is < 640 px for example

1 Like

Yup, try changing the min width of 360px to zero

Now they shrink

Okay, it might work if I set number of columns depending of page width.
But still if I have page width wide enough, cards do not stick to right and left corners.

The only solution is to stretch cards horizontally.
But if we have maximum width of cards by design, it seems not possible to set everything right.

The solution I found is to combine all of your advices, guys, set min width of card to 100% and add the separator between cells.

This looks good, but still, if we have maximum width of cards by design, it seems not possible to set everything right…

1 Like