Forum Academy Marketplace Showcase Pricing Features

How to hide dropdown choices if they are not available

I’m trying to display a list of users available for a booking by only showing their name if their booking range does not overlap with the booking range trying to be created.

The way I’ve done it up until now is to have a repeating group of users, with constraints that match the users I want (like their role). However, you’re not able to constrain a RG’s content by a LIST of items, like a list of Date Ranges which is how I want to constrict it.

So within the RG there is a button which has its visibility dependent on the user’s availability, like this:

This works (although, a problem with this method is that if I try to make a booking with exactly the same booking range as an already existing booking assigned to this user, their name still shows up. so maybe I don’t understand how “overlaps with” works. Anyway, that’s a different problem).

However, when I try to assign this same logic to a dropdown, it doesn’t work. You can’t outright HIDE the dropdown options, but you can change its caption.

This is the same expression however i am saying “NOT” 0 because I want it to change the caption to - N/A - if there IS something in the list of ranges. However this doesn’t work at all, it won’t change the caption.

As an example:
image

I would like to change how the user is chosen by going to a dropdown instead of the button list I’ve created, but I don’t understand why this is not working when it’s the same expression

I even changed the default caption to include the count of how many bookings overlap, and it displays “1” as it should.
image

I understand what’s going on here. I have to choose the value in order for it to change. I was thinking the “value” was the actual list item itself, but it’s only once it’s chosen that it becomes the dropdown’s “value”.

Once I choose the user from the dropdown, if they have an overlapping booking, the caption changes to - N/A - like I wanted.

However, what I really want to do is exclude them from the list entirely…and I figured out how!

I didn’t know there was an “advanced” option, or what I could do with it, but now I do, and learned something new!

With this setting, any users with an overlapping booking will not show up in the dropdown list.