HTTP request not working from arduino mkr NB

So i’ve made an API endpoint and then sent POSTrequests to it using postman. It worked perfectly, however, when I send the exact same POST request from an arduino mkr NB, I get error messages:

HTTP/1.1 301 Moved Permanently
Date: Thu, 14 Jul 2022 17:58:01 GMT
Content-Length: 0
Connection: keep-alive
Location: https://resqtech.bubbleapps.io/api/1.1/obj/Patients
CF-Cache-Status: DYNAMIC
Server: cloudflare
CF-RAY: 72ac24da3a0672b4-LHR

HTTP/1.1 400 Bad Request
Server: cloudflare
Date: Thu, 14 Jul 2022 17:58:01 GMT
Content-Type: text/html
Content-Length: 155
Connection: close
CF-RAY: -

400 Bad Request

400 Bad Request


cloudflare

I have sent multiple POST requests from this arduino and i know the issue isn’t that.
I have given different API keys to the arduino, but still no luck. Any idea what could be causing this?

You do a post request to that url above next to “Location” and you get those errors?

yes, the exact same post request works from postman, a post request works for a different website, however a request from this device to bubble app gives error

Hi, the subject is old but if I can help anybody by answering … the reason is that you request using HTTP. In postman the redirection to HTTPS is automatically done as you can see
in the setting by unchecking “Automatically follow redirects”.
The sad part beiing that not all arduinos manage HTTPS