In "Schedule API Workflow on a list" option set filter don't have "This Request data" option

When I try to run Schedule API Workflow on a list and put in it the desired option set depending on the current Request data user’s userHobby I don’t get such an option in the selection


But “Search for” gives me such an option

1 Like

Use “Get an option”. From there you can select from your option sets.

In the first screenshot I have “All Hobby OS” and this is “Get an option” with all the options and then I filter the option set I need depending on the current Request data, but in the drop-down list there is no This Request data only all Request data

Ah. Your confusion confused me too. Hmm…

What are you trying to do exactly?

As you can see in the screenshot I have these applications for tests. I can give you an example of how it can work. For example I get a JSON list of users to register from the outside.

{
  "users": [
    {
      "userEmail": "qweqw@xcvxv.ryrt",
      "userName": "testname",
      "userHobby": "Fishing"
    },
    {
      "userEmail": "test2@eqwrtyryryrte.r",
      "userName": "tset2",
      "userHobby": "Camping"
    }
  ]
}

For example I have a configured call to API create_user in which I can pass parameters email (text), name (text), hobby (option set). And I run this API create_user list from Request data user which I received in JSON. But I need to pass hobby parameter as option set. I wanted to take the list of all Hobby option sets and filter by the Display is This Request data users userHobby: first item. But the bubble doesn’t allow it, although in case of Do a search for it works. I understand that I can pass not option set in create_user API but text, but if in my application this API has already been applied in many places then I will have to change it everywhere. I have options how to solve this but it’s like making patches where everything should work fine.

This topic was automatically closed after 14 days. New replies are no longer allowed.