Forum Academy Marketplace Showcase Pricing Features

Inbound parse a multi-part form?

Anyone setup the sendgrid inbound parse?

The docs say this is multi-part form, but in Bubble it sure looks like json.

image

But I cannot see to grab the key:pairs. For example “from” is just a blank value if I try to store it in our logs table.

Hi @kramwe :slight_smile: I ran into the same thing and did get this to work (though I’m not 100% sure if I set it up in the correct way). I used “Detect Request Data” and set the response to JSON. When the “Detecting Request Data” screen came up for me in Bubble, it seemed like nothing was happening but the data types were returned correctly after a minute or two of sending the test email. The SendGrid settings I have for the webhook are:

Host: parse.[appname].com
URL: https://[appname]/version-test/api/1.1/wf/parse (if in development)
Spam Check: Yes
Send Raw: No

1 Like

Similar. Thanks. I also tried “Detect Request Data” and saw the loading bouncing bubble for minutes; I figured I didn’t set it up right as well.

Just to confirm, you waited on this screen. Did anything show up? How did you grab the parameters?

Right! Same here, it seems like it takes at least a couple minutes after sending a test email, and then it changes to this:

After saving, Bubble lets you use them here:

1 Like

Thanks. I’ll practice some patiences.

No problem :slight_smile: Let me know if that doesn’t do it!

Just got it! Thank you.

1 Like

Awesome! No prob! :slight_smile: