Invite friends workflow

Hi there,

I’m new to Bubble and wondered if anyone can help me figure out what the correct url should be that I include in the send email workflow of the invite button. I am working on a one-page app and this is what I have so far:[email protected]&user=regular but I get a 404 when I test it.

Basically the link should lead them to the group called “signupfriends” which is by default hidden. Do I need a condition for this group to be activated when someone clicks on the link sent to them after pressing the “invite” button?

Any help would be greatly appreciated. Thanks.

Hey @rmjjkj1 :wave:

You almost had it! :blush: So close.

So right now your URL is expecting it to go to a page called “signupfriends”. If it is a group you can set this as just another parameter. Something like this[email protected]&user=regular

(I think that is what it should be)

Then use that parameter to set a state or show the group on the page. If signupgriends = yes then set state or show the group.

Does that make sense?

Hope that helps! :blush:


For All Your No-Code Education Needs:

  • One-on-One Tutoring
  • eLearning Hub
  • Video Tutorials
  • No-Code Classes

@J805 Thank you for your help! I no longer get a 404 page.

However, since the app’s menu is in a focus group triggered by the menu icon and also loads (along with a splash screen) on page load, when I copy and place that link in the browser and hit return, I get taken to the app but the menu covers up the sign-up form. Is there a better way to set this up? How do I set up a workflow where the menu is not showing when that link is clicked. Which leads me to my second question, in the email I received, the link was not a clickable link. Should it be? Is there a way it can be?

Btw, I purchased your monthly subscription and I tried to implement the stacking order of the groups by recopying everything over to an index_2 page. How do I now make that page be the default page?

Thanks very much!

1 Like

@J805 I was able to change my index page but the other issues remain unresolved.

1 Like

@rmjjkj1 thanks for being a member! Glad you got that working. :blush: Hope you find the eLearning Hub beneficial. I make sure that everything is included in the one price, so each new video or blog post is included in your membership benefits. My goal is to regularly add new exclusive content for the members.

Hmmm, the email should be a clickable link. Most email inbox and browsers detect it automatically. Maybe add the www. or something might fix it.

Can you share a screen cast of what it looks like when you open the link? Then I can better understand what issue you are running into. :blush:

@J805 Sure. Thank you.

Here it that link that will take you to it:[email protected]

I’m going into a session right now but let me try to see what I can do after the session for you. :blush:

Im thinking… maybe try not to show the menu on page load. On page load you can do a workflow that shows the “signupfriends” group only when the parameter is not empty from the URL. Would that work?

Do you use set states to show/hide your elements?

@J805 I’ll try that. But the menu is part of the intro design look. Here’s a view to the app. I’m still trying to set it up but I need to adjust the hidden element within each group. I found that when I do that it changes the hierarchy in the elements tree.

Yes, I am using custom states to show/hide groups.

So on Page is loaded you can do a workflow like this to set your set state. Then from your set state you can trigger the menu to not open and the other group to display. Check it out:

Hope that makes sense. :blush:

1 Like

@J805 That did it!! Thank you so much.

1 Like

No problem. Glad it helped! :blush:

@J805 May I bother you with one more question. Does this look ok because it is not writing to the database.

@J805 I am struggling with the collapsing groups–they don’t seem to collapse and I understand it is because they may overlap, right? Is this the correct model and hierarchy? I have quite a few groups and it gets overwhelming when needing to adjust height size and not having them overlap. Would you recommend making them an easy number to do math with like 2000 px? Even within this mode, I still have scrolling:

Screen Shot 2021-01-06 at 7.44.21 AM

I would need to look at the editor again to see if you have everything set up correctly. :blush:

For this, it’s tricky, you need to stack everything and make sure everything collapses when hidden. If you open up your editor again I will take a look. Just ‘view only’ is fine.

Hope to help you out soon. :blush:

@J805 Here it is:

You will see that I started a new index; now I have three versions as I have struggled mastering this concept.

1 Like

Sounds good. I will look at it this afternoon for you. :blush:

Here you go, here is a short video explaining why your groups aren’t collapsing. Hope this helps! :blush:

Let me know if you have any questions.

@J805 Thank you! That helped. I went ahead and implemented it but still could not get rid of all the scrolling. Also, when I click on the menu links, the pages do not show up at the top; one has to scroll to see the content. I color coded everything so I can see/understand clearly what is going on. Here it is if you wouldn’t mind taking another look. Thanks again.

Here you go:

I just see a few groups still overlapping. You are almost there! :blush: