Forum Academy Marketplace Showcase Pricing Features

Is there a way to use Private Links from Vimeo?

Hi I was hoping to use links from Vimeo in private mode - built out my App banking on this, only to find out this morning that its not working…Help!

Hello,

Without a link to the editor it’s really hard for other users to help.

It is in private mode…not sure if you’re still able to view???

Yeah actually a run mode link is probably better.

https://credentialsystem.bubbleapps.io/version-test/video_list?debug_mode=true

Scroll to the bottom of repeating group - click the “HazCom” video - this will launch the page which the videos are played on.

Just FYI, as I’m sure you know, Vimeo has a paid service, in which you can keep vids private, it generates a “private link” - this is what I used in my program (in a thing called videos, field = ID) - When I use the private ID I get the error in the picture above. I did test to be certain I did nothing else wrong - by temporally changing the video to public on Vimeo - it then worked in my App. It seems to be something about its private nature thats not working.

Can you try to rename the parameter with something else? ID is a bit generic is used by Bubble.

It hasn’t been an issue yet - in my DB it’s called Vid ID, when I pass the parameter I shortened to ID. It worked no problem with generic YouTube videos that I used to test while building it. Only probs started when I changed to Vimeo…

But let me try out your suggestion, maybe it’s the case.

And are you 100% sure the ID is correct?

1 Like

Ok - the Vimeo ID seemed to be issue - When Vimeo generates the private ID code - they put a “/” and add a suffix to it. You don’t need the suffix

Ex. 187884226/bf76d8e827

You only need the code to the left of the “/”

Everything seems to be working fine now…thank you @emmanuel!