Issues redirecting people that aren't logged in

I’ve tried a ‘User is logged out’ workflow with ‘Go to page index’, my issue seems to be that if any parameters are included it prevents my index page from loading.

Is there a way to clear the parameters? I thought the fact that there are options for ‘send current page parameters’ and 'Send more parameters to the page would mean they don’t get sent by default…

Thanks!

They get sent by default as that is the expected behavior of the function to send parameters…if you don’t want to send parameters by default based on some condition like if the user is logged in or not, then create to workflow actions for navigation, add the appropriate conditional on each and for those that don’t need parameters, don’t send parameters.

I’m a little confused, how do you not send parameters?

Just leave them blank

This is what I have… They are blank?

Okay, so what is your issue when you say…

You are not including parameters in the screen shot, so if the index page is not loading, it is not because you are including parameters.

Behaviour with that workflow:

User navigates to: https:// www. website. co/version-test/dashboard?v=home
Browser redirects them to: https:// www. website. co/version-test/?v=home

I want the browser to redirect them to just https:// www. website. co/version-test/ (index)

Is this a bug with bubble?

Hi @thethinklab.au ,
Have you tried selecting “dynamic pages” from the Destination drop down?

If all you are doing is navigating the user as in the screen shot that shows no parameters sent, and you are getting the parameter of v=home then it is a bug…but likely on your index page you have a page is loaded workflow setting that parameter.

1 Like

This works! I also ticked ‘Replace the entry in the browser history’

I’m glad it worked. :slightly_smiling_face:

This topic was automatically closed after 70 days. New replies are no longer allowed.