JSON query returning [object Object] instead of actual JSON

Hello,

This previously worked until about two days ago it appears.

I am passing data from Bubble and calling a stored procedure in a MySQL database that returns JSON-formatted strings. The JSON is then used to do a bulk insert against the Bubble API.

This all worked great except now in the log and UI I am seeing “[object Object]” instead of the actual JSON. When I run the stored procedure manually in MySQL, the data is displayed as JSON and when I copy that into the API plugin page it works.

Here is an example in MySQL workbench:
image

And I plugged in a simple test in the editor:
image

And that returns [object Object]

This is what the logs show:
image

Any ideas?

This is normal. The logs won’t shoes you the object.

Try using this when you output to log

Basically bubble expected you pass it a native text, number, boolean, etc…

If your looking to use the object as is then you will need to add as an external object

Thank you for the reply!

I can try that although there may be a different issue because the JSON strings are getting created and being passed to the bulk data API for bubble but nothing is being inserted in Bubble DB and I’m not seeing any errors which is why I thought the [Object object] was the issue.

I submitted a big ticket and support / engineering deployed a fix so that the JSON returns as expected instead of showing [object Object]