Linking Data - What am I doing wrong here?

I am building a form to allow users to analyze a real estate deal.

The form has the ability to input the subject property information. Then you are able to add properties to compare (comparables/comps).

I have linked the two data types together. When I save and exit the form the data is saved in the proper locations. The subject property information is saved into the analyzed deal data type. The comp properties are saved to the comp_property data type.


Screenshot 2023-05-10 212745

I have a section where the user can see the deals they have created and re-open them to edit them.


However, when I re-open the form it will repopulate the subject properties information but not the comp properties info.

What am I doing wrong here? I appreciate the help!



Have you attached the right Analyze_Deal thing to the Comp_Property?
You should be able to see this on the App Data tab - locate the Analyze_Deal thing you edited and see what the value of it’s Comp_Property is.

Why not just have a single datatype?

Under App Data in Comp_Property thing it is saving the info there. When looking at Analyze_Deal thing it has the comp_property field but nothing saved in its row.

I want the user to be able to create up to 5 comp properties so I went this route. If you think something would be simpler lmk.

When the user creates a new thing, also add another action that modifies the other thing and adds this thing into it. I think that step might be missing right now