Login with Google/OAuth Not Working

ETA: it’s working now! Saving the post for future users if it happens again.

Oauth (login with Google) does not appear to be working. For example, see kcam.bubbleapps.io (I have made the app viewable).

On clicking login with Google, it takes you to the account selection page, and it redirects back to Bubble. But then instead of marking that user as signed up/logged in (as verified by Current’s users Google email), Bubble throws up an error popup, as seen in the screenshot below.

On the Google dashboard, I do have the redirect URI set to https://kcam.bubbleapps.io

and I have checked the generic uri box in Bubble’s Google plugin

Am I missing something? Is your OAuth workflow working?

Check the console window of the browser for more information so we can help

1 Like

Thanks. I checked the console, with preserve log. It says server side error after being redirected to Bubble. Here’s what Google returns to Bubble:

https://kcam.bubbleapps.io/?authuser=0&code=4/2QH2xF2SRLC7CpiA53Z1Bj7CZksv-SgfVFkTHX2VKYqfX5yt9kGN9wfRE4KYKs86ac4MjAk_e-NEPrnQmmRtcwA&prompt=consent&scope=email profile https://www.googleapis.com/auth/userinfo.profile https://www.googleapis.com/auth/userinfo.email openid&state={“oauth_provider”:“google”,“resume_key”:“1595533550864x154192729165288480”,“used_redirect_url”:“https://kcam.bubbleapps.io/”}

Here’s the console at the Google interstitial:

And after selecting the account, here’s what happens next: it redirects back to the bubble page, and shows this error (with console)

Here’s the Bubble settings (this is test account; I will change the app secret later)

And here’s the Google console:

Can we see the Social login sign up workflow? Seems like your trying to call an action that may not exist

Not too sure now. Try another plugin?

Thanks. Will try to find another plugin.

What I did is exactly what was shown below:

Been experiencing this on some of my sites too…will check if it’s all

1 Like

Same problem: Google and Facebook OAuth respond by "service is temporarily not working. There were no changes to the app prior to this happening.

1 Like

Getting same error, was working yesterday, not working today. nothing changed

1 Like

Tested in some other of my apps…not getting any errors

1 Like

Maybe it’s the plugin? Are you using the API connector in the apps that are working?

It is still not working …

I am using the plug-ins provided by bubble for the Google and FB OAuth. I tried an alternative plug-in for Google (Google OAuth 2.0 by Najmuzzaman), but that is also not working.

As reported by others. There was no change in the app, service stopped overnight.

Interestingly the message occurs after I have been redirected to Google to chose which of my Google accounts I wish to use for the OAuth process.

This error is a real issue for my business as customers who have signed up with a social account cannont access their data.


BTW: If I try to login via OAuth Google and the same email adress exists already for a user the system gives me the (correct) feedback, that this user already exists.

1 Like

This is consistent with what I’m seeing. In the Google dashboard, I can see that the Bubble app is getting associated with the Google user. Probably some error in how the data returned by Google is handled by Bubble. On return to Bubble from Google, if you parse the URL using a url decoder, it does appear to have the Google code and JSON with info. I’ll let you know if I find a solution.

I’m using the plugin, not the API Connector