Make changes to another user's field not working

I am trying to make changes to another users field, but it’s not working.

In the screenshot above, I set it to assign a value to “Referral Tokens” (which belongs to another user). However, it doesn’t work.

Privacy for Everyone else is set to view all fields.

What does your WF look like when modifying the referral tokens?

Hi Johny,

Here’s the entire workflow…

In Step 8, I am just trying to assign a reward called Referral tokens to the user that referred the Current User, who just signed up.

Thanks for helping out.

Hi @adamhholmes please can you help me?

Thanks a mil in advance!

What is your search?

I am searching for the user who’s referral code was used by the user who just signed up.

The correct user already shows up in the search…

Check your server logs…

1 Like

Hi Adam,

Here’s a screenshot for the step in the logs…

This is actually my first time of going there. Please let me know if there’s something else I should be showing you instead.

Well, it definitely shows that the User (1677752436894x11806152139901400) is being modified, and the referral_tokens field is being set to 1333

Are you saying that’s not what you’re seeing in the database?

1 Like

Good lord…

For some magical reason, this last attempt just worked properly. I tried over 20 times before I went to bed and it didn’t work.

My first attempt this morning just worked. Weird.

Thanks for your help and for showing me troubleshooting via logs.

1 Like

This topic was automatically closed after 70 days. New replies are no longer allowed.