Forum Academy Marketplace Showcase Pricing Features

🗺 Mapbox Maps - Total revamp of one of the most popular Bubble plugins from Zeroqode

Thank you, this is how that response looks in a RG-

This is the live url to see it -

Hi @tomajx, thanks for your reply.
Let us check internally if data from this API call can be filtered accordingly, (to provide only required lat and long coordinates), or any other actions/improvements are required.
Once any results will become available, we will let you know asap.

Thank you for understanding.

Regards,
Zeroqode Support Team

Thank you, not quite sure if I understood correctly, do you want me to only return lat/long coordinates from the API?
Because it is totally customizable, it’s a request to my database
Thanks!

Hi @tomajx, apologies for the delayed answer.

Yes, the developer team is now checking the proper date format from the API call to be used in this field (including the possibility to use only lat and long coordinates ). Once any result becomes available, we will let you know asap.

Regards,
Zeroqode Support Team

1 Like

Hi @tomajx, thanks for your patience.

We’ve pushed a plugin update, that has fixed the issue related to the markers list coordinates sourced from API call.

To check changes, please upgrade your plugin to the latest version (Version 1.58.0: Fixed action “Add List of Markers”) and give it a try.

If there will be anything else that we can help with about our plugin, please let me know :wink:.

Have a good weekend ahead!

Regards,
Zeroqode Support Team

1 Like

Awesome!! Great to see you actually improving the plugin based on the user needs!
I went ahead and updated the plugin (by selecting the version in this dropdown)

Removed the mapBox element, then added a new one back, and re did the workflow, unfortunately for some reason the error still persists…

Under the map you can see the RG with lat,long and address that are returned from that API call

and here’s the page itself - https://tiktavo.com/version-test/test7_9?debug_mode=true

What I can see from the API logs (that returns the coordinates), that the request is not even made to it

Hi @tomajx, thanks for the reply.

Something within your API call is conflicting with the plugin actions and thus drops the above-mentioned error.
We’ve used your test7_9 page to use our own API call, and adding the list of markers works properly.
Please see the setup example on this page and adapt your API call response by this model accordingly


Hope the provided tip will help. If the issue will persist or anything else would be required from our side, please let us know.

Regards,
Zeroqode Support Team.

1 Like

Thank you, this just seems to be some silly bug possible, I have added a second button to add the markers from your API call, and it is throwing the same error :man_shrugging:

Also, not sure why but for your API the ‘address’ is missing?
Mine is on the right, not sure if that has anything to do with this issue…

I have modified how the coordinates are returned from the API to not include anything else but the coordinates, to eliminate the room for error there.

Appreciate the help and thank you for your time, it looks so close to be working!

Hi @tomajx, thanks for your reply.
Lest us check it once again and see what might be the issue.

Once any results will become available, I will let you know.

Thank you for understanding :pray:
Regards,
Zeroqode Support Team

1 Like

@tomajx, here is the solution for your case:

  • beside indicating the latitude and longitude, for proper displaying it is required to add a marker id, named _id

We will make a small adjustment to the “Add List of Markers” action, that will require this field for setup. Once the change will come to live, we will let you know asap.

Regards,
Zeroqode Support Team

1 Like

Awesome, thank you!
Modified my response to have the _id field and it works!
It would just be nice to have it customizable, instead of it having to be _id , because we can’t always control the API responses.

Thanks again! :white_check_mark: :white_check_mark:

Hi @tomajx

We’ve pushed a plugin update, that has added an ID field to the “Add List of Markers” actions, so now it is easier to setup.

Please note that for proper display of the list, each marker id should be unique.

To check changes, please upgrade your plugin to the latest version (Version 1.60.0: minor fixes) and give it a try.

If there will be anything else that we can help with about our plugin, drop a message :wink:

Regards,
Zeroqode Support Team

1 Like