Moralis API call: header is not correct?[Solved]

I am trying to get Moralis API through with API Connector.
It did work on Postman and received a response right.

But I cannot get it through with the following API setting on bubble.
What am doing wrong here?

Honestly not sure but try moving the “accept” key and value to the header for the actual call. Shared headers will run for ALL calls under that API, which might explain it if your current call doesn’t need an “accept” to be sent. If not, check that you’ve correctly formatted the key and value for all headers?

Thank you so much!
It worked without the “accept”!

1 Like

hey what’s the value you put in for q?

Eth address, I think. You can leave it blank In the API Connector. Then, use it as a query parameter where input data is applied.

this worked for you? the api connector isn’t initializing without the q field filled out

this is my setup


for when i try to initialize:

i also tried moving accept / application/json to the shared headers and got the same result.

when i try these same keys and values on the moralis web3apis page, it works: Moralis | The Ultimate Web3 Development Platform

i dont understand why

i figured out my issue. dummy mistake