Navigate - open an external website: only working in step-by-step mode?

I have set up a workflow to redirect Stripe customers to 3D Secure link. This however, only seems to actually redirect the user when I run the workflow in step-by-step mode.

If I run the page at normal speed, the workflow operates as expected but does not redirect the user once complete.

I have also tried sending the user to an internal page, carrying across the redirect url as a parameter and then redirecting them from the new internal page. But the same behaviour happens.

What am i missing here?

Hi there, @garypyne… let me start this response by saying I have no idea what is causing your issue nor do I know if what I am about to suggest will address it. That being said, I ran into the same situation a few days ago with a workflow that would only run the last action in step-by-step mode, and it drove me nuts until I stumbled ass backwards into a “solution.”

So, who knows, maybe the same thing I did will work for you, and that thing is to add a step directly in front of the redirect step and use the Add a pause before next step action in the added step. I didn’t even change the default pause length, and now the workflow completes as expected.

Anyway, it can’t hurt for you to give that a shot, and I hope it helps.


1 Like

Ok, i lied! Turns out 1000ms wasn’t enough. Setting it to 2000ms is working for me.

Strange little quirk…

Funny, I did actually try this!
Sadly didn’t seem to help in my situation though.

1 Like

This topic was automatically closed after 70 days. New replies are no longer allowed.