New Entity Being Created and I can't figure out how


I’ve inherited an application that is managing students in a school. One of the use cases lets the user create a student info record. Part of the that record is a sub-record called username. When I tab out of the student’s last name field, an entry in the username table is being created. My problem is, I can’t figure out exactly how that is happening. Before the username is created, I need to strip out any illegal characters from the first/last name. I’ve scoured the events when the user tabs out of the last name field and still can’t figure out how this entry is being created. I’ve tried stepping through with the debugger. When the first breakpoint is hit, the entry is already created; I can see it in the data tab.

Any help that you can give is appreciated.

Tom Wojeck

What exactly have you tried, the step by step workflow run or set up a breakpoint in one workflow action that is not the first action?

Because the first option would show which step is creating the entry and the second would be skipping the previous actions and there may lie what you seek.

I’ve done both. I’ve put the workflow in step by step mode and I’ve also put breakpoints where I think the entry should be created.

I have a standard FirstName/LastName field entry setup. When I put the debugger in step-by-step mode, when I tab out of the last name field, the program stops at the first workflow point. At this stage I refresh the table the I’m interested in and the entry is already there. So, I can’t even seem to get to the point where I define where the entry is being created.

Thanks again for your intput!

Are there any custom or scheduled workflows being triggered? Also, can you share screenshots of the workflow steps?

A long shot, but double check to see if this box is checked on a Make changes to a thing workflow.


I’ve been looking for that. So far I haven’t seen any instances where that checkbox used, but I will keep looking. As an aside, do you know if there is any way to search the application for the data element that is being created? I’ve tried the search feature in the top right corner, but that doesn’t do the trick.

Just to clarify, the search feature does let you search by Action > “Create a New Thing” - and “Make changes to a thing”. (Albeit at a high level). (Apologies if you meant you already looked through it - wasn’t sure based on what you wrote).

Otherwise, check the Server Logs tab. You should be able to zoom in on the workflow that’s creating the new record from there.

That helped. So, I think that I ran into an anomaly running the app in debug mode. It seemed to be executing the workflow that I created multiple times. It sounds crazy, but that’s the only explanation I can find.

1 Like

This topic was automatically closed after 70 days. New replies are no longer allowed.