[New Extension] Bulk import from CSV file for Option Set

works for me, thanks a lot!

1 Like

Hey @arturio, when I click “upload CSV” and select the file, the file doesn’t load up. I’ve tried with your sample test_import.csv and still nothing. Have you ever seen this happen? I’m using CSV file.

@mloveland33 did you create option set and attributes before you import CSV file?
File will not be displayed in plugin, you just need to click Submit after you select the file.

It continues to say there is a bug. Very simple import for translations.

Display with the attribute of “Spanish”

My CSV is

Hello , Hola

Even just loading one row it says bug.

Hi @mloveland33
did you use paid or free extension? If it was free extension, I fixed it and updated to version 1.0.4

just purchased the pro extension 1.1.2 but couldnt import attributes
any idea ?

Hi @stephane
I just checked and got the same issue. If you want I can return money. Or you can wait until I fix it (probably tomorrow)

thank you! if you could fix it by tomorrow it would be great so you can keep the money :slight_smile:

Hi @stephane
sorry for the late response.
It doesn’t work for me only for one of the Option Sets. It is very strange.
I created new Option Sets and it works. Please try again with new Option Set. If it doesn’t work for you, tell me please.

Open Inspector on Submit, and check Console/ network if any errors, I just used the free extension, and got error to import my csv with only 1 column of data, issue was related that some value had comma in middle of text or some UTF caracter issue. blocking the Import process after few rows, If Import is not 100 correct, then you do not see any error popping, it’s just like nothing happenning. fixing the few rows on my csv helps to solve the issue, and the 300 rows have been imported successfully. Thanks for this extension.

1 Like

Hi @arturio,

Love your tool! But I’m having trouble importing Hebrew language words from a CSV file (I used in the free version if it’s related). Only 23 random words out of 1,400 are being uploaded to the linked option set. Any ideas why? Thanks for your help!