[New feature] Cloudflare for all

Had the same message. Clear cookies for bubble and cache and log back in. Should resolve.

I can’t seem to get Cloudflare setup correctly with Google Domains for my bare domain. @peterj?

Thank you

Hey @peterj Your Amazing! ( Man Hug! )

Speed is super fast already getting comments from users and puts apps like mines up there with the big names across the globe in regards to speed and reliability.

Speechless!

Bubble is not in a bubble this platform is going to be on the world stage!

#Gobubble!

4 Likes

Hey, I’ve never seen this before but after creating those 2 CNAME records, I now get this…
Edited: FIXED by clearing cache/history in Chrome :slight_smile:

Problem solved with the creation of a free DNS provider at NAMECHEAP.

Just had to setup the DNS of Namecheap in my old DNS provider (OVH - take 30 minutes)

freedns2.registrar-servers.com
freedns1.registrar-servers.com

And create the new entry in the Namecheap setup (CNAME and ALIAS)

Go back to Bubble. Delete, refresh, add. That’s it !

The advanced formula for DNS Pro in mailchimp is like 15$ per year to protect your domain better, but seems great with the free plan.

3 Likes

:tada: :tada: :tada:
WOW…
:tada: :tada: :tada:

Thank you @peterj and Bubble… I transferred over last night and it was completely seamless… ticked the box in Bubble, removed my A names, added my CNAME, and BINGO… it all just worked… I never saw a moment when my app wasn’t accessible during the process.

Page loads 2-3x faster now…

Yours gratefully,
Antony.

3 Likes

Exceptional Update, works like a charme! :100::+1::+1::+1:

For the ones who have their Domain registered at Google
A brief summary for Google Domain Registrar users and legacy plan holders moving over to cloudflare option with almost no downtime exptectations. Google made problems with moving to CNAME records with new “point to bubble´s -.io” address on the CNAME-@-record, so I switched the DNS right over to Cloudflare, but leaving Google as registrar of my domain:

  1. Switch on in bubble the option in Domain / email: “Accelerate this domain with Cloudflare” to “on”
  2. register at cloudflare with your domain (ie “myapp.com”), enter your domain, check for new DNS proposals (2)
  3. Go to Google Domains and your domain-name records/DNS, deactivate first of all the DNSSEC Service to avoid unwanted / uncontrolled downtimes on change process. This is important.
  4. take the DNS servers cloudflare proposed for you (2, with names as ie “adel.ns.cloudflare.com” and “clark.ns.cloudflare.com”) and copy it to your Google domain DNS list - activate them instead of the 4 google DNS.
  5. Go back to Cloudflare and take over the parameters for reactivating DNSSEC for your domain at Google Domains. Parameters for settings are ie: xxxx for key; 13: ECDSA/P256/SHA256 for Algo; 2: SHA256 for Digest Type; 1e29fe40a79bde9c7daace711XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX for Digest. Reactivate your DNSSEC with this new parameters for your safety, directly at Google Domains.
  6. Scroll down in Google Domains / DNS to “Your Ressources” and now delete the 2 “old” A records pointing to bubble (having an IP-4 address rightside ie 54.68.12.205 or other, which was needed before). Cloudflare DNS services should be activated with a green mark by now, recheck this there.
  7. Now, go to Bubble / Domain / email and click “check settings” under your Domain Name field. Message should be “You´re all set. myapp.com is working and ready to go!”
    Done, at my side with no real downtime at all.
4 Likes

Hi , maybe my posting could help, …I have also Google Domains,

Unfortunately I have ask again why my domain doesn’t work together with Cloudflare.

I’ve setup the domain correctly, but still get the following message in Settings:

However, my domain is setup correctly as a CNAME only:

I still cannot access my app with this domain:

I’ve tried and re-tried for days now without success. I hope someone from Bubble support can have a look at this?

@louis.brauer You’ve discovered an uncommon edge case.

Your domain has a “CAA” record. Only the Certificate Authority on record on that DNS entry is permitted to issue certificates for any subdomain on openbooking.ch. In this case, the CAA is letsencrypt.org, which differs from the Certificate Authority Cloudflare uses.

In order to get Cloudflare working, you’ll need to remove this entry:

id 39319
opcode QUERY
rcode NOERROR
flags QR RD RA
;QUESTION
openbooking.ch. IN CAA
;ANSWER
openbooking.ch. 59 IN CAA 0 issue "letsencrypt.org"
;AUTHORITY
;ADDITIONAL
2 Likes

What is the process for someone who registered their domain with namecheap already using cloudflare nameservers? The subdomain my app uses is set to bypass Cloudflare proxies. What steps should I take to configure that subdomain with Bubble’s Cloudflare implementation?

Subdomains are the easiest case, since subdomains support CNAMEs with no issues.

If I’m reading your comment correctly, your subdomain has a “grey cloud” on Cloudflare… when you tick the checkbox to “Accelerate this domain using Cloudflare” on Bubble, you’ll receive a new DNS record.

We proxy on Cloudflare, so when you change your CNAME to match the provided record, your site will be proxied under our account’s rules regardless of what settings you use on your account.

1 Like

Yeah with Cloudflare proxy status (cloud) control is automatically disabled because it’s controlled by the Bubble. I’m still not sure if is’t working correctly like I mentioned before in my previous post.

Same thing here… :cry::sob:

Quick question for everyone benefiting from improved Cloudflare speed -
Do the UI elements load quicker but then the Data takes the same amount of time to load, causing slightly more time before the page looking like it’s done loaded until the actual Text and Data shows up?

Or does the speed increase of the cached visual elements allow the Data retrieval to then fire sooner and appear with the same delay as before?

(I’m not sure if Data usually loads immediately on page load, or if the Data waits for the elements and then loads)

This question is more for data heavy pages with multiple Searches and/or reusable elements where there would usually be a delay in the Data showing up

4 Likes

Great question. I’d love to see some benchmarks of a data-intensive page with Cloudflare, and the same page on a cloned app without Cloudflare.

2 Likes

what did you mean in step #2? Create an account with Cloudfare?
Like this:

Can someone screenshot exact how to set everything up with Google domains and cloudflare??? I followed the steps above and created a cloudflare account. The ssl is active. But my url only loads http, no https. Before I switched everything was fine. My understanding is that my domain registrar is Google domains and my name servers are on cloudflare along with the ssl cert.