Forum Academy Marketplace Showcase Pricing Features

📅[New Plugin] Air Calendar (FullCalendar)

Hi @ZeroqodeSupport thanks for the reply…

I don’t have any special customization in my calendar.
No workflow actions.
Just the calendar in a blank page.

The calendar is getting events from my database (just have 20 events created).

full_data is a Date

I am not creating or deleting anything from my database. The “events” are the same in all the tests, and sometimes the calendar works, sometimes it doesn’t.

Here is the Console:

Refreshing the page…

OTHER PROBLEM!

I have created a workflow to change the view from dayGridMonth to timeGredDay when the user click a date. Evething is working nice and the calendar do chenges the view.

The problem is that when I change the view, I can’t change also the date.
So I keep always opening the same day…

This is very basic… What am I missing here?

@ZeroqodeSupport and @levon

Sorry about all this doubts/issues… :roll_eyes:

I have two more here…

  1. In every month my calendar shows the first week of next month…

  1. To speed up the the loading, I have made a constrain to show only the events that are inside the selected month. Look what I have done:

Note that “full_data” is the date of my event

Unfortunatelly, when I do this constraint, I get this error message:

image

And also, noticed that the load time increases… :neutral_face:

How the process works? The plugin loads all the events listed in the “Search for” or it do its own constraint, loading only the ones inside the month?

I had this same issue and fixed it as per below video.

2 Likes

Hi @rpetribu, sorry for the delayed reply (due to weekend time).
Allow us to reply below on reported issues:

As a possible cause, on the first-page load, something is blocking the calendar element from proper initializing.
In order to check what’s wrong with your setup and test it out in your workspace, would it be convenient for you to add our [email protected] as a collaborator of your app?

Enter your Bubble editor page → Settings → “Collaboration” tab → Invite a user (email).

(Note: you can add our support account to the collaborators list even if your app is on a Free/Hobby plan.)

We will check your setup and do a few tests in an attempt to find the root cause and help you fix it.

A small related bugfix will come in a short time. Once it will come to live, we will let you know.

Kindly note that this relates to the Full Calendar functionality itself. Unfortunately, we can’t do much in this regard, a solution would be to submit a ticket to the Full Calendar Team.

The developer team is working now on the optimization of this process, how to speed up the loading. Presently, we cannot provide the exact time estimates on this matter, sorry. But we strive to improve this process as soon as possible.

Thank you for understanding.
Regards,

Zeroqode Support Team

1 Like

Hi @lee1 ! Thank you so much for your help. It worked :pray:

3 Likes

Hi @ZeroqodeSupport

+1 if you can include the timezone support feature update. I’m running into user experience issues when their organizations are operating between different timezones.

Thank you,
Gilles

2 Likes

@gilles ,

We are working on it at the moment. Hope to deliver the “timezone” update soon. :slightly_smiling_face: :handshake:

Have a good Friday and a wonderful weekend ahead!
Regards,
Zeroqode Support Team

2 Likes

Hi @ZeroqodeSupport .

Can you please check if this is happening with you too?

Note that I have different types of rows in my calendar…
Bold lines, Thin lines, dotted lines, double lines…

This is happening in the dayGridMonth view as well…

Hi @rpetribu, thanks for your message.
We’ve checked this issue on our side and the calendar grid is displaying properly, both in day & month view.

In case you are using Chrome browser, then the issue with calendar grid lines/rows might be related to the recent Chrome 91 update, that has changed something in the lines display.

Thus, we recently have updated the plugin with a bugfix, which fixed that.
Please update your plugin to version 2.14.0 (dayGridView rendering fix) and give it a try. It should fix the issue mentioned above.


Please let us know if after the plugin update it got solved.

Regards,
Zeroqode Support Team

2 Likes

Dear @muneer.hameer & @gilles, thanks for your patience and understanding.

Allow us to inform you that we’ve released the “Timezone” feature for the Air Calendar plugin :fireworks: :rocket:.

This feature will allow users to easily manage calendar records made in different time zones.
We have added a field with the time zone of the page owner for the correct saving of events:

It is needed to specify the page owner time zone in this field, in order to use this feature.

The “timezone offset display seconds” and “timezone offset save seconds” states the difference between the owner’s time zone and the current calendar time zone.

"Timezone offset display seconds" - used for correct time display: Screenshot by Lightshot.

"Timezone offset save seconds" - used to save time correctly: Screenshot by Lightshot.

For the right setup and guidance, please use as a reference the Live Demo/Editor pages and supporting documentation, which was recently updated.

Note: As the added feature is quite complex, we strongly recommend before plugin update to make an app database backup, in order to avoid data loss while configuring the functionality.

It is also necessary to remove and then install the plugin element so that the latest update takes effect and no errors appear.
Please be aware that removing the plugin element will impact the previous element settings (fields, checkboxes etc.). Therefore, before reinstall the plugin element please make sure you remember all the plugin element settings.

In case during the updated plugin usage any issue will appear, we will gladly appreciate your feedback and as much provided details as you can about your use case (screencast/screenshots of workflows/conditions, console, etc.)

Looking forward to your feedback.

Regards,
Zeroqode Support Team

2 Likes

Hello @ZeroqodeSupport,

Thanks for maintaining this plugin.

Is it possible to turn off the ability to drag new events on the map completely? Even though the “Event draggable?” and “Event resizable?” are “no” and the “allow editing blocked events?” is “no”, the calendar still allows the user to drag new events onto it, although the events aren’t saved and later disappear.

One approach is to put a transparent Bubble group on top of the map, but I’d like it to be scrollable if possible and adding this group on top makes it so the user can’t scroll.

Hi @andersan1, thanks for your appreciation and sorry for the delayed reply (due to the weekend).

Sure thing it is possible, for that, please modify accordingly two more fields:

You can also manage the particular events settings, see an example

Hope it helps. In case there is anything else that we can help with, please let me know.

Regards,
Zeroqode Support Team.

1 Like

Totally Random,

On the ResourceDayGrid view, it only shows 2 events and then groups the rest;

Is there any way to display all events on that view? I’ve got plenty of room to show all of them, and when you click on the +6 more, it takes you to the DayGrid view without the resource which takes away the point of having the resources.

If we could customize how many it displays that would be fantastic!

Hi @bcart0v, thanks for reaching out.

Please use the following field in plugin element settings:


It will allow you to set up an event limit per day limit which the rest of the events will show in a popover.

Hope it helps. In case any other plugin-related questions will appear, please let us know.
Regards,

Zeroqode Support Team

1 Like

:man_facepalming: I must have overlooked that 100 times… That worked.

Thanks!

2 Likes

Need Help getting re-oriented to Air Calendar.

I’ve been away from Bubble since about the time zeroqode announced taking over the Air suite of plugins. I was on the verge of getting Air Calendar to work in my app, but a lot has obviously changed with Zeroqode making many changes in rapid succession.

Today I tried updating the plugin all the way to 2.15.0. OOPS! The calendar does not appear and I’m getting debugger errors. (I didn’t make a not of exactly what they were but there was a reference to 5.6.0.

Scanning the many version options, I chose to v. 2.1.2, “Added Render action. …” which immediately preceded the version that “Updated Library 5.6.0 and bugs fixed”.

Without any real testing, this one looks like the calendar I expect to see, so I decided to take the next step to v. 2.2.0, “Updated Library 5.6.0”.
This one is aesthetically wrong and has an error that the license key is invalid.

I haven’t read all of what’s transpired in this topic since Zeroqode took over but I see in some messages that it’s necessary to uninstall the plugin and reinstall it. I’m not sure exactly what that means but it sounds like completely resizing and reconfiguring every instance of the plugin throughout the app.

Does it mean completely uninstalling the plugin via the plugins page?

So, having been away for a couple of months and being far behind in just trying to digest this topic thread, I’m hoping someone can give me the bottom line on how to get up to date and get things working with the latest version of Air Calendar.

Hey @ZeroqodeSupport

I’m running into some new issues where the calendar will just not appear on the page at times which is causing issues and complaints from users. Here’s a console error that appears whenever the calendar doesn’t load. Any ideas?

Hi @laurence, thanks for your message.

I’m afraid that by current restraints of the Bubble platform (plugin element is not always updating correspondingly to the plugin update) it is necessary to remove and then install the plugin element (calendar itself) so that the latest update takes effect and no errors appear. After that - of course, set it up accordingly to your case, using for reference the Live Demo /Editor pages and supporting documentation, which was recently updated.
There is no need to uninstall completely the plugin via the plugins page.

Hi @avern87, thanks for your message.

I’m afraid that provided information is not enough to identify the cause of the issue.
Please check your use case by the following steps and tell us if it got solved:

  • the plugin is updated to the last version
  • the plugin element (calendar) on-page from the previous version of the plugin is deleted, and a new one is added back with a proper setup.
    In case all of the above is done and the issue persists, please provide screenshots/screencast of your setup workflows & plugin settings (for the screencast recording, let me please suggest using the Loom tool).

Looking forward to your reply.
Regards,

Zeroqode Support Team

1 Like

:+1:

Thanks. I have things underway. I overlooked that I’d lose my workflows when deleting the plugin, so I am still working to rebuild them. But overall, I’m incredibly relieved that Zeroqode is really on top of stabilizing and improving AirCalendar.

Just a couple of questions have come up.

In this case I have two instances of AirCalendar on the page. One is for the plan. The second is for the actual activity:

image

Since I’m showing the date above the pair of calendars, The day (Thursday) at the top of each individual calendar is superfluous and doesn’t look good. Is there an option to remove this? If not, can that option be added?

Also, the space (“gutter”?) between events is pretty large and seems wasteful of vertical space. Is there a way to control its size? Honestly, I’ve been through the options many times and it seem that I find something new every time I go through it.

I’ll keep working my way through the docs and doing my best to put AirCalendar through its paces.

Thanks again for the great work you’re doing with this essential plugin.

1 Like