Forum Academy Marketplace Showcase Pricing Features

[New plugin] Beautiful Customizable Charts and Graphs (ApexCharts.js)

Hi @amna,

This is normal behaviour when you have null/undefined values in your data series. These values are sometimes present in groupings. Make sure to disable ‘do not skip empty groups’ in all your data series (including the category series). If these null/undefined values are still visible than it is likely that there are empty/missing values in your data.

Hi @Thimo !

Thanks for the quick reactivity and for your demo !

It’s almost that :slight_smile:
The problem in my case is that the number of data to append to the graph will vary in function of the project. (For project 1, there’s 2 “product sales” data to display, for project 2 there’s 4, etc…).
Do you know how can I run a similar workflow with a variable number of data to append ?

Thanks again for the quick answer !
Best,
Thomas

@thomas.guyot You can have a couple of ‘append data series’ workflows after each other and conditionally turn them on/off depending on the amount of data series. So, depending on the data, you can only append 2 instead of 5 data series for example. Would that work?

Hi @Thimo,

Quick and dirty solution, but it works :wink:
After all there’s no point to display more than 5-6 data series on a graph like this !

Super plugin, super reactivity, thanks a lot !
Thomas

1 Like

Update 5.2.0

Every chart now has a workflow action to create the PNG url of that chart. When this workflow is run, the PNG URL is created. When this URL is ready the ‘PNG URL Is Created’ event will be triggered. The PNG URL is accessible as an element state: Chart A’s PNG URL.

This will be great for users to share a picture of a chart, include it in emails, PDFs etc.

The demo page is updated to see it in action:
ezgif-4-220ccbef06e5

1 Like

Update 5.3.0

1 - Added the option to disable the color change on hover.
2 - Multiple minor improvements.

I just bought the plugin but I saw that it doesn’t have the prefix “R$” which is the currency here in Brazil. Is it possible to add?

Captura de Tela 2020-11-28 às 02.44.42

Hi @mequelussi, I will add it for you so it will be available when the new update launches! I will also see if I can change it to an input field so you are not limited to a fixed set of options :slight_smile:

Update 5.4.0

Changed the prefix and suffix dropdowns with input fields! @mequelussi

1 Like

It worked, thank you.

How do I change the font and make the percentage value bolder?

Captura de Tela 2020-11-28 às 22.46.10

@mequelussi You can change the font using the standard font picker inside the property settings:

2020-11-29 om 12.11.29

Hi Thimo.
Thanks for your awesome work, very happy with the plugin so far!
I’ve got a similar question to Amna about the graph skipping empty groups.
What’s weird is I have 2 graph, one is based on ‘counts’ and when the groups are empty, the graph line is visible (on zero) which is what I want:
(well I guess technically those groups aren’t ‘empty’, but the counts are returning ‘0’)
good-graph
but for my other graph based on ‘sums’, then it just skips the empty groups which looks ugly:
bad-graph

How can I fix that? If it’s empty (null) then ideally it should just behave as if it’s ‘0’.
(i’ve tried enabling/disabling ‘do not skip empty groups’ but it made no difference)

Thanks a lot for your help :slight_smile:

@Raceto9 I will take a look if I can provide an option to replace all null/undefined values in a Y-axis data series by 0! That would be great in your and @amna’s use case :slight_smile:

Update 5.5.0

Added the option to replace null/undefined values with 0 for the Line, Area and Area - multiple lines chart! @Raceto9 @amna

2020-11-30 om 20.01.57

Brilliant. Best support ever mate :slight_smile:
My chart looks beautifulllll now aahha
Definitely recommending your plugin!

1 Like

Thank you for the support on this!!

1 Like

Hi Thimo,
Something weird happened when I updated my plugin to 5.5.0 following your update of yesterday.
The radial chart I used on my dashboard just lost its alignment.
I used to have ‘20’ in ‘Y axis offset’ in order to center it vertically but since yesterday’s update I can’t make it centered anymore (or it could be one of the past 3 updates … I think yesterday when I updated to 5.5.0 I moved up 3 or 4 updates at once).
Basically if I leave ‘Y axis offset’ empty, it’s aligned towards the top:
default

And then whatever I put in the ‘Y axis offset’, it aligns to the bottom (i’ve tried anything from -100, to -10, -1, 1, 10, 20, 100 etc…), whatever I put in that field I get the below result:
minus100toplus100

Any idea?
(FYI - all paddings are at 0)

Thanks a lot!

@Raceto9 I will send you a PM se we can take a better look!

Thanks!
Just to confirm for everybody else in the forum the problem was fixed with version 5.5.1.
Again Thimo, thanks a lot for the great support! fixed my issue within 30min!!

:+1: :+1:

1 Like

Hi @Thimo!

This plug-in is incredible!

My team and I have a question regarding gathering the most updated data from our app data section in order to display the most recent results. Specifically, this is for a donut chart. Below is a screenshot of what we have at the moment for our series data:

image

and this is our data from our app data:

How can we adjust the series data to show the most recent amounts per category by modified date?