Forum Academy Marketplace Showcase Pricing Features

💾 New plugin - dataTables - Updated: 09/23/2018 -- NEW DESIGN!

Hello, @Bubbleboy @yusaney1.

We’ve updated the plugin and here are notes on what it was changed/updated:

  1. Added error handling for the Refresh action. Now Refresh action returns an error message as state with instructions, and triggers an event “Error Happened”, just follow the instructions in the “Error” state message for fix it. There is no more bubble error alert.
  2. Sorting is only alphabetical that causes the table working only with text data, and can sort it only alphabetically.
  3. Fixed! Now bubble’s inspect button is visible when table is on the page.

Please upgrade to the latest version, refresh page and give a try.

@ahmed.marzouki this is not possible with the current algorithm of the plugin. Sorry.

Regards,
ZQ Team.

Hello, why I couldn"t see the real change with datables when I add or delete thing like the repeating group, I did refresh of the page and I tried refresh datatables after adding or deleting something in the workflow but I had an alert with this error https://datatables.net/manual/tech-notes/3

@ZeroqodeSupport thanks updated and graded new element on new page just for completeness.

The refresh although I can see this in the page debugger running does not refresh the table! I appreciate you’ve update the documentation but there’s nothing explicitly stating how the refresh works… So I’ve made a logical assumption

refresh

Using version 2.2.0

On refresh it throws this error

Requested unknown parameter ‘1’ for row 0, column 1. For more information about this error, please see http://datatables.net/tn/4

But have this error is clear the table does update

When using version 2.3.0. there are no errors but the table does not update

It also looks like your demo version is no longer working

Is any chance you could possibly update your demo to include a refresh function.

I’ve tested it in a number of different ways and scenarios it runs but actually doesn’t update the table.

Thanks in advance

Hello, everyone.

We’ve updated the demo page with latest version, and setup the page as how it should work.
Here’s the link https://zeroqode-demo-16.bubbleapps.io/datatables ; check and try replicate the workflow idea.
As for Refresh action it is used for another thing, so for example if you’ll need to rewrite data in table.

Thanks for patience and understanding.
Regards, ZQ Team.

1 Like

@ZeroqodeSupport what version number is this update? I am only seeing the latest version in the plugin as 2.3.0. that was the one with the refresh issue.
.
Thanks for updaing the demo with the refresh feature but in 2.3.0 that is not working.

Have you forgotten to push the update? When i copy the element from the demo…it states Datatables plugin is not installed…so thats more than likey a version issue.

the latest update is 2.3.0. Did you try uninstalling and reinstalling the plugin?
If you still have the error “is not installed” please file a bug report with Bubble - https://bubble.io/bug_report

@levon as this was purchased vs subscribed does this master if I uninstall? And re install. Yep I’ll do the bug report direct with bubble

hmm. not sure, safer would be to go with the bug report

see this https://forum.zeroqode.com/t/multi-uploader-missing-element/1544/4

1 Like

Thanks I’ll check with @Bubble that if I uninstall a paid plugin and re install I will not be charged again

@levon @ZeroqodeSupport ought the plugin a few days ago and can’t get something to work. We have Projects and each users has their own projects. I have isolated them by added a new field called “Will Bid”.

I am then trying to filter by this “Will Bid” but it’s either 1) Showing all projects in the data base or 2) Not showing anything at all.

How do I fix this???

When adding the filter, I get this blank screen.

Here is the filter by “Unique ID field” & “Will bid” contains “user”

When I put no filter, then every Project in the data base by all users shows up.

All Projects are showing up.

@levon @ZeroqodeSupport I also keep getting this error message.

1 Like

Thanks for contacting us!
We’ll check this issue now, and update you soon on the matter.
Kind regards,
Zeroqode Team.

@mgray Hello.

Could you please provide more details on the issue, like settings/workflow with video maybe so we could help you better. And steps to reproduce issue of your use case.
Thanks for understanding.

Regards,
Zeroqode Team.

Hello

I think this plugin is great and has saved me a lot off time and I look forward to future features and updates.
One problem that I have run into while using the data tables is when using lists.

I have lists inside a database thing which is item1, item2, item3 ……………
when you use join with “,” it moves each item to the next line where they don’t belong and if you don’t use it the items from every thing is in the first row.

Has anyone else had this problem before or has a solution.

Thanks Josh

Hi again

@ZeroqodeSupport as per previous question I have found I would be able to make everything work if you could add “line_break” functionality within rows. I have tried using “line_break” and it just ignores it within the rows.

Thanks Josh

Hi Josh, we’ll try to add this, but can’t commit to an ETA

Hi @Josh123

We tested out the possibility of adding it, however seems like not a feasible solution to make it work that way, mostly due to how Bubble works with lists and not a plugin feature.
Thanks for understanding.

Regards,
Zeroqode Team.

Dear @levon @ZeroqodeSupport

As always a great plugin! I found a need to use this plugin and works well for the most part but I am running in to 2 issues.

Issue 1
I would like to show a list of site names which are linked to a Location. I am converting to a list of text hoping it will give me the site names separated by a (,)

19%20PM

but it throwing this error ?

26%20PM

Issue 2

When I try and download a CSV file from the table it is throwing this error also?
52%20PM

Is this something Im doing wrong here?

Happy to share editor if need be

Cheers @ZeroqodeSupport

Hi there @timgarrett111, the best way to provide me app access is to add in collaboration in your app settings [email protected].

Thank you,
BR.
Zeroqode team.