[New plugin] Fully Customizable Table / Grid

Hi @harvest01 Yes you can definitely use an API as data source for the plugin. I found an old demo with bitcoin data from an API for you to check out: Pluginpreview | Bubble Editor :slight_smile:

Thanks @Thimo.

We also noticed that - when we add columns using workflows dynamically, the data changes are not reflecting on the table/grid data dynamically, whereas it works when the columns are directly added to the table/grid without using workflows.

Same thing with the “conditional formatting” (html code) that we put in the dynamic columns are not working, whereas if it is directly added to the table/grid it works.

Is this a bug or not a supported scenario? Thanks for your help, as always.

Hi @Thimo,

I hope you’re doing well. I’m having trouble displaying the table grid. Here’s the scenario:

I have a page with tabs, and some of the blocks, including the table grid, are not visible initially. As a result, the tables display an infinite “Loading…” state. This isn’t related to the data since I’m just using hardcoded text.

When I copy the table from these blocks and display it on page load, it works fine. I also tried to re-render on tab switch, but no luck.

Do you have any ideas why this might be happening and how to fix it?

Thanks!

@partha @Thimo Noticed this as well! Conditionals are not working for any of my added columns. For the data, I used a workflow action to refresh the table which updated the values.

@harvest01 @partha Added columns are static. I do not have the ability to know if/when the data in a column that is added by workflows gets updated. If you want to update an appended column, you should remove it and append it again

@partha I did found a bug in the when appending a column with HTML/bbCode. I pushed an update 2.61.9 so it should work as expected now. I have made a demo to show you that it works: Pluginpreview | Bubble Editor :slight_smile:

@roman.labish This means that the table crashed. There is a big chance this is caused by your data. Not sure what you mean by ‘hardcoded text’, but I will send you a pm so we can take a better look (maybe it is caused by something else)! :slight_smile:

Hi @Thimo, thanks much! Think there might be a bug with this new version. I just tried putting in values for the HTML when adding a column and the position is now -1 for each column. When I add a column with the value “test” in the HTML, it loads the value in the column before that one. So if I add column #3 with “test”, the “test” value loads only in column #2. Consistent for every column with a value in the HTML - it’s all shifted one column to the left.

Column to the right of revenue has percentage but it’s swapped over for the actual revenue column.
Screenshot 2023-03-21 at 2.26.04 PM

Revenue should say $–mm but instead its shown for the column that comes before that which is health.
Screenshot 2023-03-21 at 2.26.07 PM

@harvest01 That is weird, that is exactly the issue the new version should prevent. I will send you a PM so we can take a better look at the issue!

Thanks @Thimo for the html/bbcode fix. I will check it out.

For refreshing the data, will the “rerender table/grid work”? If I remove and add the same column again, will it be appended to the end of the table, or from where it was removed. I will try that anyways, but thought if that would be a challenge to resolve.

No. The columns you append are static and I do not have the ability to update the data they contain. I do not have the ability to change this unfortunately, this is a Bubble plugin limitation. I do see that this could be a nice feature to have, I will try to see if I can request this feature somewhere :slight_smile:

It will be appended at the end of the table. Maybe you can make a workflow that removes all the appended columns and append them again so you can keep the order and update the data?

Hi, @Thimo

I have a date column and it wont show up when I preview it. Is there something I am missing? I put in all of the data correctly

thanks

@poutdirect You need to format the data as a text. You can see on the demo page how that would work:

Pluginpreview | Bubble Editor

Does that help?

Thanks for the response.

Hi @Thimo

Minor UI bug: if you enable the checkboxes column and render a table with no data, you still see the checkbox column label and sort arrows.

hey @Thimo,
It looks like the disable sorting field may no longer be working.

When I try to disable sorting on the current version the columns are still sortable. When I revert to the 2.14 release the columns specified in the disable columns field are not sortable.

@wlcraig93 I was able to reproduce this issue! I just pushed update 2.62.0 that should fix this issue :slight_smile:

Hi @Thimo
Love the plugin
I’ve spent a few hours on this, but just cant figure it out
I’m trying to show a company logo and company name in one cell
Tried many things, but this feels as close as I can get it. Any help is much appreciated!

Thank you!

Hi @calumbrannan!

You can’t actually refer to a cell in the table like that. I have updated the demo page for you to showcase how you can build your HTML dynamically :slight_smile:


Editor of demo (second table, 4th column): Pluginpreview | Bubble Editor

2 Likes

You’re a legend!! Thank you @Thimo

Awesome, thanks so much @Thimo!! I’ll update to that version