Not able to upload Bubble swagger file into Dropsource

Im having an issue uploading Bubble’s swagger file into Dropsource. I am getting errors even though importing has worked for me in the past months:

Invalid spec. Click here to see the errors that need to be fixed.

Dropsource encountered an unknown error while importing your API. Please contact customer support for assistance.

Is this a bug on Bubble’s end that is pending a fix?

I did get a response via Dropsource from Support, anyway to resolve this?

Ok our engineers have looked into this, we had an issue due to the size of your spec file and the fact that it has been updated a lot of times, it was causing a memory/timeout issue in the platform backend. We have actually reached out to Bubble to ask them if they can trim the size of the Swagger files they generate but that issue is ongoing. In the meantime our engineers have pushed up a fix that will hopefully help with your project. If you can reload the editor then attempt the API spec upload again - if you still get an error message please wait a couple of minutes then reload again. Please let me know if this works.
–Sue

This topic was automatically closed after 14 days. New replies are no longer allowed.