Object not being created and displayed

I have no idea what I’m doing wrong as there are no errors: I’m creating a basic pricing app for bookkeepers: there is a client type with one of the fields being “bookkeeping”. Bookkeeping itself is a type comprising fields “bank transaction fees”, “invoice fees”, etc. “total”.

I have an event in which the client.Bookkeeping object is updated with the figures inputted in various input boxes. BUT the client.bookkeeping.total field is just showing as blank and when I look at the debugger it looks like the field is “empty”.

Please help because I have been on this for days and I simply don’t understand what I am doing wrong!

It seems to me like you are trying to populate a field that is expecting datatype thing (bookkeeping) with a number. Can you share the field specifically that you are trying to populate and how you set it up in the datatype?

@amirmalik123

Thanks for the reply- don’t think that’s the issue but here is the structure:

Client has data fields a) Name (text type) b) Turnover (number) c) Bookkeeping (Bookkeeping type)

Bookkeeping Type has fields: a) Bank transactions quote (number) b) Invoicing quote (number) …etc and c) Total (number)

Let’s say we have input boxes somewhere in the app where we someone populates the Book keeping fields above when they click submit button the event is thing to change “the clients bookkeeping” and the field in that changed is the Total field.

No errors are thrown out and it seems to make sense logically but I can’t seem to see anything, and whenever I try to extract any data of the Client.Bookkeeping. total data it’s null!

@amirmalik123
one thing I see is that you have your clients bookkeeping total content format set to Integer, but shouldn’t it be decimal?

Anyways - I’ve replicated a oversimplified version of your setup on my end and was able to get it to work.

  1. I set up a repeating group set to client data type
  2. outside of the repeating group, I have another group set to client data type, and then a group within that, set to the bookkeeping data type.

When i click the client name in 1. it sets the client group to the client I clicked in 2.

It also sets the bookkeeping data type as well of the client
image

When I click save it does the following:

Everything seemed to work.

Thank you, much appreciated. I’ve tried to do things your way too, in exactly the same manner, and I simply don’t understand what I am doing wrong, but the bookkeeping object seems to be being created according to the debugger but it still doesn’t show!

Here is a simple client/bookeeping Group. I clicked through in the repeating group and the client in the repeating group is transferred successfully into this group. But when I click the “save button” the bookkeeping total, based on an input box elsewhere, just doesn’t show anything. The bordered box is where it should be.

So the debugger here shows that it is successfully executing the “450” to be changed on the bookkeeping’s total field but the 450 is not showing up in the box on ABC client!

Very odd…

I wonder if the “create if the thing doesn’t exist” being “No” has anything to do with this? Because technically the Client’s Book-keeping field has no values up to this point. I’m not sure if that is the same as not existing, and if so, how to change the “no” default to “yes”.

I have finally figured out what the problem was and either it’s a limitation of my understanding perhaps or quite a quirky way that Bubble operates. So basically, I was trying to change Client’s Bookkeeping field with input data from input forms elsewhere. The issue is that Client’s Bookkeeping is actually a separate object/thing and therefore it doesn’t behave in the same way as any normal field. It doesn’t exist until it’s created.

So, whereas you can simply say change client name field to xyz , when I was saying to it to change clients bookkeeping’s total to whatever, it was failing because it sees clients bookkeeping doesnt exist and then it doesnt do anything. So first thing you have to do is create a bookkeeping thing and then say to it to change clients bookkeeping to “results of step 1”.

This was not at all intuitive to me!

Is this intuitive to others? Was I missing a basic concept?