One field does not increment in backend WF

Hi everyone,

I have a backend WF that should increment a year to year+1 when the month in the looping process is 12 (December). So for instance, I want to create a list of things spaced out by months starting from current date to a future date, so say I am in Nov 2023, (so month= 11 and year=2023), in the next loop, I want month to be 12 (december and year to still be 2023), but in the next one I want month to be 1 (January) and year to be 2024. I am getting the correct value increment for the month (from 12 to 1) but the year does not increment itself by one, even though I have specified the increment in the worfklow, see below:

Anyone has any idea what could be wrong ?

there is something wrong with the call, can you try , after +

current_date : round down to year : plus year 1

Hi ,

I have tried this but am getting an error

I have also tried what you recommended but am also getting an error:

Any idea what might be wrong? The increment does work with the month, it makes no sense to me why it does not work with the year, as both are numbers.

as you see, when month is < 11 (before november), i do increment by 1 and this one works:

It turns out, I had used a calculated value for my parameter, which was the problem! I had to do this instead, for it to work:


Thanks everyone for reading through.