Overage cost $130 - 12 hours - development credits

It has been an expensive night for me. Yesterday, I implemented a new workflow in the development edition and forgot to set a condition. So it kept running. It used around 50,000 Wu per hour. The total right now is +/-700,000 Wu. Some things need to be done here, Bubble!

  • There should be the possibility to disable overage on the Development edition.
  • Overage was hit yesterday around 20:00 CET/CEST - I got an email about it this morning at 11:00 CET/CEST. There is more than 12 hours between hitting the max and receiving the email.
  • Maybe some security mechanism should be put in place when Workload Units skyrocket. Or when development is a lot higher then live?

Let this be a warning for everyone. I will email support, and hope that they will cover the overcosts.


kind of crazy how long it took to get that email. Ideally an overage would email and SMS text immediately


I guess that should be posted in Idea + on the Idea Board.

And this is bad for sure:

Notifications should be sent as soon as issue happens.

Thats why I put it in bug

This is terrifying. It would be great to have an option to set a max limit to WU consumption for any workflow.

Notification won’t stop this things from happening, there should be a hard cap (daily, hourly) especially on development version.


I received an email back, a one-time compensation and references to how things work (blogs). No update on safety mechanisms or why I received the email so late. It seems I might be less fortunate next time, and it could turn out to be a costly mistake.

1 Like

this will be a constant issue and with the only mechanism being to contact the overwhelmed support, it isn’t great for either party going forwards. Like it or lump it though I guess.

I still can’t get over how the are charging for WUs in Dev mode when OG model would allow continuous fixing and optimising!!

Good luck getting enough WU’s to be able to apply a fix & test it next time.

1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.