Forum Documentation Showcase Pricing Learn more

Page Height Reset

One thing i keep running into is when you use states and load a RG full of data and then scroll, the page gets longer to account for the data.

When you load a NEW group VIA state… the page height determines the EXT VERT SCROLL data load content. IF the page was made VERY long by a previous states visible RG, the new data being displayed in the NEW state can take a long time to load due to this long page created.

REALLY NEED A WAY TO RESET THE PAGE HEIGHT

Is this possible without a page refresh.

OR the ext VERT scroll needs to have a cap on it

1 Like

Yeah I agree! I’m currently having the same issue with few of my projects. It’s not really user friendly and I’m forced to add page refresh to workflows. Really annoying…

Hmmm… it seems like the easy fix would be to use a scroll to top function and capping the first load to maybe 25 records… then after the page is scrolled to Y pos set the condition on the data to no cap or a much higher cap. But this is not ideal

Seems like having a max cap of 40 records on the ext vert scroll would be sufficient to keep this from happening until the 40 records have been scrolled past

In one of my cases I open long agreements (20 pages). in a pop up window or in a group. I can scroll on the top after popup is closed but I have a lot of white space on the bottom and that is not ideal. It is easy scroll down and just see white.

Do you know if it’s even technically possible to resize canvas height that would remove scrolling?

You’re probably already doing this, but when you hide the group that holds the long repeating group, do you have the box checked that says “Collapse this element’s height when hidden?”

Yes but the page does not get shorter when an object collapses… it just adds more height to the page but never subtracts it.

Which is fine if the data was capped on the first load to 20 or 40 until reaching the scroll point

Be nice if it was an option to select the initial data count and then scroll beyond it to load more. This could maybe be solved it the RG scroll type could be dynamic. switch from fixed to ext vert scroll at scroll position.

Right now seems the only option is to create conditions to change the record count

i dunno. it might not be?? so maybe other options for limiting data would help in the interm

@emmanuel is it possible to get comment on this? This creates issues on one page applications.

1 Like

+1! This is a very frustrating issue that reveals to the user that page loads aren’t fast, we’re just show/hiding content based on state.

Hi all,

I know it’s old post but I was searching for a fix for this issue as well. They way I handled that is just by a simple trick - you need to add additional empty group that will cover the area you want to eliminate on group change. You set it as always hidden and make sure that “Collapse this element’s height when hidden” is check. That’s all.

It’s not super pro but this fixed problems with mobile version of my app.

Cheers!

1 Like