Forum Academy Marketplace Showcase Pricing Features

PDF Conjurer (updated free plugin, now saving to database)

Hey @vini_brito, great plugin and thank you for your work!

Is ti possible to create a table like this one, can’t seem to figure out which element to use.

It’s basically 4 pieces of independent dynamic data styled in a table.

Thanks!

Yes! Just not with the exact same appearance :slightly_smiling_face:

Hi @vini_brito would really appreciate your thoughts on this one. Thanks a lot

Thanks for the quick reply.

So I would just use a multi column, correct?

Also is there a page or document with a Changelog? I know you post updates and explain the new features to this forum but with so many posts it is hard to find them.

Thanks!

@vini_brito indexing can temporarily be accomplished by getting a list of numbers… something like below. Is it worth me making a whole separate plugin to do this, or is this easy support for your development stack? Let me know:

//variables to declare
const properties = {
    item_count: 26
}

run_server = function(properties, context) {
    const indexes = []
    for(let i = 1; i <= properties.item_count; i++) {
        indexes.push(i);
    }
    return indexes;
}

console.log(run_server(properties, null));

Hi

I’m creating a PDF and it’s all working great. However, I now want to add some different styles with different fonts and can’t seem to get that working.

I’ve followed the instructions for setting the style and the font within it (i.e. I use the “load font” action, name the font, and point to the ttf font files; then subsequently us that same font name in the style) but it doesn’t even try and download the PDF. If I change the style back to use “Roboto” then it works fine.

Any ideas? Or has anyone a working demo using different fonts I could look at?

Thanks

Hi Nick! Well, right now I do not have free time to do it, but bubblers already can create lists by themselves, it is more of a Bubble skill that needs to be learned than a plugin feature, so I am unsure if a plugin would be a good idea here.

@thedew Not yet, this costs time and effort, but right now I cannot justify spending the energy needed to maintain that. I wish I could, though.

And you can tinker with multi columns and tables as well. Tinkering is the right approach with this plugin, always! :blush:

1 Like

Hi Keiraro, may I know if you successfully load japanese font and it works or not?

Hi thomas, I gave up usung thie plugin because of the font issue, so I donk’t know if it work now

First of all, thanks for this good plugin.
Just one question, anyone successfully using load font to display chinese characters.
I tried various method to load font, however this is no luck.
If anyone use load font successfully, please give me some hint. Thx a lot!!!

Hi @vini_brito

I have a question regarding the advanced table group. I’m trying to create invoice line items on my pdf which works fine with the “advanced table model”. This can drop all lines that I’ve created in bubble on the model at once. However, some invoice lines have additional information. I want this additional information to be included just below the respective invoice line, just like here below:

Really hope you would be able to help me out with this? Thx!

Hey @vini_brito !

First off, love the plug-in, incredibly powerful stuff. I’m having an issue and not sure if it’s user error, a bug or a limitation. I am successfully able to create my PDF, and have it downloaded or saved as a file, using the ‘Conjure PDFModel A’ action in my workflow.

From there on, I’m trying to call the actual PDF in order to save it to a field on an object and send it through an API. I’ve seen other posts here that see to say that actions after a ‘Conjure PDFModel’ action should be able to reference that action as a ‘Result of step…’ but I don’t have that as an option in future steps. Similarly, I’ve seen folks post about using the ‘Conjure PDF’ and ‘Upload PDF’ actions, but they both require referencing a Previous step result, but I don’t have any ‘Result of step…’ as an option.

What am I doing wrong?

Composite screenshot of both my Conjure actions below:

You are mixing backend and frontend actions but they do not mix, I will rename them to better differentiate.
Stick to either one. “PDF Model A” is frontend, without this is backend :blush:

Check here for more guidance, docs still in alpha stage: https://www.unlimitedbubbling.dev/docs_public

Vini,
Parabens pelo plugin … estou apanhando um pouco mais esta saindo kk
acredito que minha duvida seja igual do nosso amigo, nao consigo deixar meu pdf mais bonito, digo inserir cores, ou elementos para ajudar na divisao dos dados.

teria um tutorial que posso nos ajudar, principalmente agora com essas atualizacoes, os vídeos que estao no ar tanto do renato, quanto dos outros youtuber nao falam muito sobre essa parte de designer

Hi @vini_brito @nicholasrbarrow ,
I am running in the exact same CORS issue.


My WF is the simpliest:

With the Insert img

I am running on the latest version and rolled back down to 1.6 where the issue happened again. I also composed the img url with an https.

Had you identified any workaround or way to deal with this issue ? All my attempt on shared apps in this thread remained unfruitful. From what I see in your code bubble is taking care of fetching the image to serve it to the plugin, do you see any option to mitigate this ?

Thanks in advance, and I should have started with this thks for this versatile and efficient plugin

Nicolas

Hello! I’ve found Chrome to be very difficult to work with because of this issue. One way to work around this is to use a CORS Proxy, but they are a bit more difficult to setup and deploy. CORS Anywhere helps support this. Here’s a copy/paste from Stack:

CORS Anywhere helps with accessing data from other websites that is normally forbidden by the same origin policy of web browsers. This is done by proxying requests to these sites via a server (written in Node.js, in this case).

“To use the API, just prefix the URL with the API URL.”. That’s really all of it. So, instead of requesting http://example.com, you will request https://cors-anywhere.herokuapp.com/http://example.com. CORS Anywhere will then make the request on behalf of your application, and add CORS headers to the response so that your web application can process the response.

However, I know CORS Anywhere is free, but if you’re worried about future limitations or worried about having this intermediary (not sure how it’ll work with private files) then you may need to host your own. Google and YouTube would be good places to start.

Make sure your browser is completely up to date. Sometimes things could go wrong here. I know I’m running chrome 103 or higher and am not experiencing CORS-related issues.

1 Like

@nbelin89 Did you upload this image directly in the app editor file manager? Or was it uploaded in run mode? If so, try uploading it in run mode as a user and let me know if the issue persists.

@vini_brito I have tried it as you suggested, this works now fine. Thanks for the quick help

1 Like

Hi @nicholasrbarrow
thanks for your quick help. I will try your proposals: hosting the file on self managed server and setting a proxy in between. I tend to prefer the first one though.
I also tried to upload the file through the file uploader as suggested by vini, and this suits my actual usecase well has I want an admin to edit a logo.

2 Likes

Hi @vini_brito I sent you a bug report a cou;le of weeks back about pdf conjurer not working on safari, I’ve also experienced issues trying to generate a pdf when using an ipad. Are there any preference settings on mac products and in safari that I should be using?

I have paying users on my app so it would be great to know how to advise them to avoid issues?

Thanks
Robbie