PDF Conjurer (updated free plugin, now saving to database)

hey thanks for letting me know, I don’t know why but my email went dark last week, I’ll try to fix it.
P.S: Just fixed it.

1 Like

Thank you, however I still don’t see the update. Have you pushed it? Ty

Hi Hoke! No, the update was not about the plugin itself, but rather my email who had issues for a few days and now is working again. I will push something about the plugin very soon, doing some additional preparation.

6 Likes

ola. seu plugin conjurer PDF é excelente!!! ele será continuado ?

I’ve got the same issue.

Workflow error - Plugin action PDF Conjurer (backend) | Conjure PDF error: TypeError: context.async is not a function at eval (eval at build_function (/var/task/util/util_harness.js:37:12), :69:51) at eval (eval at build_function (/var/task/util/util_harness.js:37:12), :263:8) at /var/task/plugin_api_v4_alpha.js:198:35 at harness (/var/task/harness.js:115:21) at /var/task/harness.js:154:70 at withGlobalHandlers (/var/task/harness.js:66:41) at Runtime.myHandler [as handler] (/var/task/harness.js:154:16) at Runtime.handleOnceNonStreaming (file:///var/runtime/index.mjs:1173:29)

Did you find a solution?

1 Like

Bom dia Vinicius, como vai?

Eu estou começando a estudar o PDF Conjurer pois tem muitas pessoas que utilizam e falam muito bem do plugin, parabéns! Ele parece mesmo ser bem poderoso!

Precisarei gerar PDFs com alguns requisitos e não sei se o PDF Conjurer vai me permitir…

Exemplos:

  • Preciso gerar PDFs que juntem outros arquivos PDF já existentes num só…precisarei saber qual a página em que inicia cada PDF para gerar índice (sumário).

  • Preciso gerar um índice interativo nesse PDF, com link interno onde o usuário pode clicar no item do índice e ser direcionado automaticamente para a página deste item.

Bom trabalho com a atualização dele, espero que consiga para não ser descontinuado pelo Bubble.

Abraço!

PS: Segue um exemplo do site do TRT2 que gera um arquivo PDF como eu preciso gerar os meus (clique aqui).

Has anyone found a way to stack 2 sections on top of each other but inside of a table?

For example something like this

Vinicius answered this above, he’s updating it and the plugin shouldn’t be deprecated by March 12th (fortunately!)

3 Likes

You’re a legend @vini_brito ! Awesome plug-in and really happy I don’t have to replace it with something else

1 Like

I had the same error

Hello, I know the PDF Conjurer plugin is being deprecated, but it was still functioning properly at the moment. Is anyone else experiencing issues with table header styles? It seems like the workflow isn’t referencing the table header style at all.

TYIA

Hello, I have problem with blank pdf.
Sometimes when a user generates a confirmation, the pdf is empty.
Other times, the same user using the same browser generates the pdf fine.
Data from inputs are always save correctly to the database, but sometimes pdf that uses the same data from those inputs is blank. Any idea whats’s wrong?

@vini_brito Any update on progress on an update to the new API to avoid depreciation? Do you have an eta on completion?

We have 100s of daily users relying on PDF generation working, so we will need to rush to find a new solution if anything changes. At least a 1-week warning prior to depreciation will be critical if something has changed.

1 Like

Hi AJ! Next week is the probable ETA considering my current progress.

6 Likes

Perfect, thank you for the update! :pray:

1 Like


continua dando o aviso que o plugin será descontinuado

Thank you very much for updating the plugin.

Apparently now, we have to obtain a license on the website https://www.unlimitedbubbling.dev/ and insert it into the plugin’s start.

On the website, when I enter the email, the following message appears: “Request failed, here is a fallback license.”
I’ve inserted the provided license anyway.

But the system still shows this error below.

The plugin PDF Conjurer / action Start a PDF Model threw the following error: ReferenceError: Buffer is not defined
at eval (PLUGIN_1543086664409x454646894723334140/PDF-Conjurer-element_action–PDF-Model-Start-.js:3:1141)

Is this error possibly due to some configuration on my part or with the plugin?

Best regards,
Rogerio

Hello and thanks vini-Brito.
I have the same error (Buffer is not defined and license) which occurs, the pdf is nevertheless generated correctly.
Cordialy.

Hey guys, I appreciate you taking the time to report, just pushed a fix for the buffer error, try and let me know!

Thank you a lot!
Now, It seems to be working to me.

Best regards,
Rogerio