Plugin Announcement: Rich Text Editor

@sam8 Thanks for pushing this forward! I know you can’t be everything to everyone, but consolidating a few ideas that were listed above and would really help our team at Marlow out.

  • Ampersand doesn’t show correctly (ever). I noticed it initially when I copied and pasted from a Gdoc and then tried to just print it without the copy-paste. (it shows up as “&amp ;” without marking up to the ampersand sign.

  • Header values are showing on copy-paste: First image shows the pasted version into the editor. Second one shows the printed version in “text”.
    Screen Shot 2020-03-18 at 6.16.59 PM

  • When copied and pasted, URLs are lost. This is problematic for my team given how much we’re copying and pasting messages / resources for our members.

  • Finally, it would be really helpful to have more than H1 and H2 — Or be able to control the size of H1 / H2. We often use H3 / H4

+1 for templates. Does this exist yet?
+1 for autosave. Looks like Quill offers this feature.

1 Like

Thanks for that feedback Mary! We’re adding these to our to-do list, which we’re working on now.

The one I haven’t been able to reproduce is the URL copying/pasting. When I copy text that’s a link into the RTE, it preserves the link. There’s an outstanding bug on our list where if you copy and paste a raw URL, an extra “/” gets added, so we’ll obviously fix that.

+1 on extend to fit not working. Any update on when this will be fixed?

1 Like

Hi @michaelchang5161 and @maryfox20! You both mentioned the extend-to-fit option not working, but I’m having trouble getting this bug to reproduce. Did this by any chance have something to do with groups, copy/pasting, images, or anything else you can think of?

I have the same bug.

hi @sam8 @allenyang I just updated to the new version of the text plugin and now I get this error when opening the text editor in a popup. Frustrating!

The plugin Rich Text Editor (Beta) / action Reset a Rich Text Input threw the following error: anonymous
https://dhtiece9044ep.cloudfront.net/package/run_debug_js/cf1329e90ddc7dde02f7329704420d3f90ae7c41fea62d3302ea134a9a34618e/xfalse/x5:18:463150
L@https://dhtiece9044ep.cloudfront.net/package/run_debug_js/cf1329e90ddc7dde02f7329704420d3f90ae7c41fea62d3302ea134a9a34618e/xfalse/x5:18:451142 (please report this to the plugin author)

Rolled back to the 1st version and it works again, there is an issue with this new version of the plugin.

1 Like

I have an issue
When I insert a video
and then display it in a text elemnt
The width of youtube video goes so wide beyond my element size
Any help plz?
Thanks

1 Like

Hi Steven. I’m sorry you’re getting an error while trying to load the editor in a plugin. We have not been able to get a reproduction of this error, so would you mind sharing a link to your editor (you can send it to me separately or file a support ticket) so I can see what’s going on and get to the bottom of this?

HI @sam8 I removed it and reinstalled it to see if this was the issue and now I can not get it to load at all with either version, so I have just given up with it and moving on to a purchased plugin. I may come back to it when I have time to setup an issues demo.

Hi Steven - understood that you’ve moved on! We would like to investigate this bug though, since it’s caused you so much trouble but we aren’t seeing it on our end.

Please DM Sam or me your app ID (when you’re in the editor, the app ID is in the URL, in the part that says ‘…&id=…’).

Thanks!

@StevenM - a fix went out last night that should cover the issue you were seeing. If you want to give it a try today or any point in the future, I hope you are able to use it without issue.

Hey @sam8

I noticed a couple of visual discrepancies and was wondering if you can help clear them up.

  • Padding added although my settings don’t have any
  • Alignment of icons (left side)
  • Different applies to H1-H4 icons

image

Thank you for a great plugin

Hi @AliFarahat!

Thanks for pointing out the icon coloration - it’s fixed now. As far as padding & icon alignment go, this is working as intended - these styles are defaults of the javascript library we’re using to create this editor.

I hope that helps!

1 Like

Hello,

The Initial Content is not rendering for me from the database. The Data is stored correctly but I am unable to render it.



Can you please let me know if it is an issue with the plugin or my implementation?

1 Like

HI @udaysy007 I noticed the same thing and the way I solved this is by “reseting” the content on load and then it appears the query to pull in the content. I suspect that it is an issue with the javascript loading the query first and by resetting you are initiating the query after the element has loaded properly.

I think form memory in the workflow you can specify to reset the content for the text editor on page load or on pop up open depending on how you have used it.

Cheers

Steven

HI @sam I did test again with the same process and no errors this time so what ever you did it fixed the issue.

One page of mine took about 10 seconds to load or more. I ended up deleting this plugin.

Seems to be loading some kind of cdn that it can’t reach at the time. The plugin is initialized before the page is loaded, which might be a concern.

Ah that makes sense, and why I had to play around with it to get it to load data. I haven’t noticed it effecting the loading speed, but I am using it in a popup so it maybe loading in the background.

Popups are not loading initially.