Forum Academy Marketplace Showcase Pricing Features

{Plugin} - Full Calendar Scheduler Suite

I’m sorry you’re experiencing this. Can you submit a but request to Bubble support? I can’t explain the discrepancy, it’s above my pay grade.

Maybe you’d have to replace the element completely but that doesn’t make sense either as I didn’t replace the element in the plugin, I only added input properties.

They’ll probably tell me to uninstall and reinstall the plugin but then do I need to go through the purchase process again?
What do you think of that option?

I think it sucks. I can push 1 more upgrade. I’ll do it tonight. Maybe it will trick your app.

I scanned the forum and found a case where they had the same issue but with another plugin.
Apparently, the solution is to delete the calendar element and creating it again.
This didn’t involve deleting the plugin - just the element.
I’ll give that a shot but I’ll create a test page first - just to be sure.
I’ll let you know how that works out.

Just checking. Is this correct? TEST BAFC - Calendar Element?
image

yeah. can you try upgrading to this version? I just pushed this

Many thanks Jared. That worked :slight_smile:

1 Like

One problem I found is when the calendar opens my headers are missing.
I go to the week view and then back to day view and the headers are there.

Then if I make a booking the headers are gone.
Again, I click week view then day view and the headers are back.

You need to explicitly set the views for those buttons

The calendar is timezone aware but can’t read thoughts. There’s a lot of potential wants from the end user so no assumptions are made other than you setting these appropriately.

Start by setting up your buttons

https://jared-gibb.gitbook.io/fullcalendar-plugin-suite/elements/calendar/input-fields/calendar-header-formatting#left-nav-middle-nav-right-nav-buttons

next,

it’s taking you out of a resource view when it renders events for some reason it sounds like

Check your initial calendar view setting too

Sure. I can go check but remember that this was all working before you removed the initialize calendar. So’ I’m just reporting issues as I see them.

Fixed.
I had the initial view set to resourceTimeGridDay in the Calendar initialisation.
That didn’t come across with the upgrade, it defaulted to a setting without headers.

The update was marked as a breaking change - a breaking change means that it will ‘break’ some of your settings/workflows and you’ll need to redo some things yourself :wink:

I would assume that all the settings you had in the initialise workflow would need to be updated in to the new element inspector settings.

Sometimes after you update a plugin you need to clear your cache and restart your editor for it to take effect :slight_smile:

1 Like

Thanks for the information. For some reason I assumed the plugin upgrade would migrate the data. Anyhow, live and learn :wink:

Hi Jared
I found the below that fixed the initial calendar load.
However, if you check the next screenshots, the click event goes back to no headers.
Please point me to where the calendar view is set in that case.
Thanks, Mark.

I tried to replicate an issue that I spotted by using your demo site.
Unfortunately it froze (probably because there are a few errors - see below).
Anyhow, my default colour is not showing in the booking (it was previously).
It seems that the 1st custom colour is being populated.

errors are gone. still not sure what you’re indicating with your issue though. even the default color is working for events as you can see in this example. i simply cant reproduce the bugs you are saying…

please see this example to see the bugs you mention are not bugs on my end

Actually two issues. This is issue #1:

This is issue #2 that I assume is due to a breaking change that I cannot find where to fix.

turn off click into day via the element inspector. use the a ‘calendar day has been clicked event’ WF, use the change view and use the appropriate view.

does that make sense?