Forum Academy Marketplace Showcase Pricing Features

💥 [PLUGIN RELEASE] Advanced Export to PDF: Whole Page / Single Element

Thanks BubbleSam…

I will try to suppress the image.

Hey @BubbleSam. I’ve been getting an error that the element id does not exist while it does.


Hi there,
Are you using it as #content?
Could you please send us your app url?
Thanks!

1 Like

Hey. My bad!

I was making changes on some other page and testing it on some other page similar to the other one.

1 Like

@BubbleSam like @MattDot, we 're also having issues with images from an external server (AWS) showing up in Bubble page but not in PDF file. Is there a solution for this / something we’re not doing right? We have client presentation tomorrow and are really hoping we can present this feature.

Thanks!

@MattDot were you able to resolve this? We’re having the same issue with images stored in AWS.

Hi @benedict ,
You can try this solution 💥 [PLUGIN RELEASE] Advanced Export to PDF: Whole Page / Single Element - #177 by BubbleSam

If it doesn’t work, I’m afraid there’s no easy solution for this. This is known as CORS issue

Thanks @BubbleSam. We were able to resolve this using the info at the link you shared.

1 Like

Hi There,

Just installed the plugin to do some tests…
Action “Convert A PDF Converter” does not appear in my workflow
image

Can you help me?

Great! Happy to hear that!

Hi there,
Did you add the pdf element on your page?

I think there should be a basic tutorial, including Classify…

I Put an ID to delimit the group I wanna print, like that
image

Then I Set the plugin
image

Does not works… It says could not find AreaDeImpressao
image

Can you tell me the path? :slight_smile:

Your tutorial could have some basic videos…

Solved !!! Just add #AreaDeImpressao
Impressive Plugin, the speed is awesome !!!
It is certainly worth a try !
Congratulations :clap: :clap: :clap:

2 Likes

Olá. Estou gostando do plugin. É um dos melhores que encontrei, MAS tem um sério problema para meu app. Ele não está imprimindo corretamente no modo landscape em dispositivos Apple.
Cotador Simplificado - Cotação neste link, imprime perfeitamente. Mas se passar desta largura dá erro, como no link seguinte. Independente de estar landscape ou portrait.
Cotador Simplificado - Cotação

Alguém aqui já teve um problema assim?

Hi,

The plugin worked fine until just now when we got app breaking issues:

1: Sometimes the rendered PDF is a black page on Mac. On PC we get no black PDFs. I’ve viewed it in MacOS viewer, Adobes and Google Chromes, and on a PC, all with the same result. The web page rendered contains what is shown below.

2a: We have a loop generating multiple pages. We update the page content (a RG) and wait 5 secs before generating a PDF from the new page content. Sometimes, the number next to the QR code does not change in the generated PDF. Instead it’s the number from the previous page. The QR code change as it should. Both the number and QR code are fetched from the RG cells data type so the data is loaded, and the correct number is visible on screen. Below you can see that the QR code has changed but not the number. Also the name of the PDF contains the number correct number range:

2b: Sometimes, only one or a few numbers are wrong, not all number in the PDF. The two lists below are exact copies so the number 5555 is wrong. The QR codes are the same as you can see. Correct numbers are shown on the web page.

2c: Sometimes, some QR codes are not rendered in the PDF at all, giving a blank area.

3: Sometimes it takes over a minute to generate one PDF page.

Best, Peter

Hi philledille,

I’ve just converted a page to PDF and saved it to DB…
How to make it private?

Tks in advance!

@BubbleSam Did you see my post above?

Hello @BubbleSam ,

I would like to know how page break works on your plugin ?

I would like to print a page with a RG and break the page every 4 rows (height is always the same). Is it something possible to do with your plugin ?

@Newman I found it hard to control the page breaks when using a RG. So I instead print one page at a time in a loop. But I have very specific needs printing sticky labels.

Why would someone code to require a # at the beginning???!!! Thank you for figuring this out!