Forum Academy Marketplace Showcase Pricing Features

💥 [PLUGIN RELEASE] Advanced Export to PDF: Whole Page / Single Element

Hello! I have a problem with the plugin working. After the whole page is loaded, saving to PDF stops working. The percentage of completion stops at 95 and nothing else happens (I have two elements going to export 2: a regular group and a group in which there is a repeating group. Previously, this functionality worked every other time: it loaded a part of the document if you start loading immediately after loading the page. If you wait, you have already managed to export everything, but now it stops at 95 and that’s it.

Hi @rshatskiy thank you for reporting this.
Could you please make a simple app to reproduce the issue? It’s hard to understand what happens without a demo app…

Thanks for your quick response, I have recorded a short video that shows how my application works. It all starts with the fact that I click the “Download in PDF” button. I start to display the% complete. It goes up to 95% and stops. File download does not start. Next, I demonstrate how it looks on a workflow. Clicking the button calls Convert PDFConverter A, where the capture elements have two groups - Title and Plan. Within the Plan group is a repeating group.

I am having this same issue. Mine goes to 90% and stops. I even deleted it and started over pasting the work flow from another converter element that is still functioning. I tried renaming the ID attribute and everything. Can not figure out what is causing this… Any help?
image

Update, if I put a break in workflow on the creation of PDF and wait for about 10 seconds before clicking “Run Next” It will generate a PDF however it does not work with a 10000ms pause in workflow… I moved the working PDF Converter to the page that is not working and it didn’t work either. Moved it back to where it was and it works fine. Grouped elements within the group I am trying to generate into a new group and reconfigured and my percentage is getting up to 96.67% before it freezes. My page has one small logo image and the rest is text. Any help would be greatly appreciated. @BubbleSam

@BubbleSam Another update, it looks like a picture element I have in the group is what is causing the issue. It is just a signature capture file type .png. If I remove it, it works amazing. If I add it, it crashes. Let me know if you have any ideas.

Update: It is definitely the image in the image element. I can place the element on the page but as soon as I reference the png image on file it stops working. If I upload a static jpg version of the exact same file it works! I uploaded a jpg version of the file into the database and referenced it dynamically. This also works. It’s just the PNG file type that is causing my issue. Please let me know if you know a workaround for this without having to buy a file converter plugin. Thanks in advance.

Thank you. I was able to make make the element full size behind the mobile elements on the page and it is working great until my issue below. 💥 [PLUGIN RELEASE] Advanced Export to PDF: Whole Page / Single Element - #150 by b.kenfield

Hi @b.kenfield , @rshatskiy

Sorry for the late reply, our office is in quarantine these days…

It looks like an issue with CORS, are you hosting your image on another domain?

Could you please try this solution:

Hi @BubbleSam, I did not try that. I went ahead and made the change and it does not seem to make any difference… still stopping at 90% or so when the PNG is visible on the page. Sending you a PM with the file name.

Hi @b.kenfield ,

Thank you for the provided info. Where the image comes from? Does your application host it or it comes from an external website / source?

Hi @BubbleSam

Thanks for being an active plugin author, and for creating an awesome plugin.

I’m experiencing weird behavior where the text doesn’t wrap within a text box when the screenshot is captured. To be clear, all of the text within the text box is visible on the screen and doesn’t require scrolling.

Here is a screenshot of how the text is shown on the page:

Here is a screenshot of how the text is in the PDF.
Screen Shot 2021-09-14 at 1.18.49 PM

I really need this text to wrap properly in the text box like it’s seen on the screen. Any suggestions?

Hi @jj11 ,

Tank you for your warm feedback!!

This plugin uses html2canvas. The described issues is a known bug in that library. It was reported a long time ago (September 2019) and it looks like it’s still not fixed :frowning: