Forum Academy Marketplace Showcase Pricing Features

[PLUGIN] - VideoJS Advanced + YouTube, Vimeo, Wistia, HLS, DASH, MUX, Pre-roll Ads (plus more)

No worries at all.
So you may want to hide the Controls (there’s an option for that if you needed it) and if you could send me a screenshot of the videoPlayer element with the settings showing, I might be able to spot the problem. Here’s the editor for the previous link just in case that helps!

If you still can’t get it working then if you don’t mind sharing your editor with me, I’ll jump in and fix it for you.

Paul-testing-4 | Bubble Editor

Anyone experiencing issues using plug-in? Seems like unpkg.com servers are down.

1 Like

Ohh… So most of the scripts are embedded into the plugin itself meaning they’re hosted somewhere in AWS (except for mux and wave surfer) but what’s not working? I’ll take a look first thing in the morning for you if it’s still playing up.

I am having issues with a specific page not loading and getting the “waiting on unplug.com” in the bottom corner…. Is it related to this plug-in?

I don’t think so, it’s something else. Can you send me the URL to that page so I can check it?
PM if you prefer.

Just sent

Yeah, i found the mux and wavesurfer scripts with the inspector and they are hosted on unpkg. Seems to be up now!

1 Like

Hey should be working now. Unpkg is back up.

1 Like

Yes, using the bubble editor your provided I was able to identify the problem quickly.

It seems that even though I kept the background enabled (for this functionality), when the background color was 100% transparent, it still did not work.

I set the background to be 99% transparent, ensured that the background was enabled, and now it works perfectly.

Thank you!

1 Like

Hey, @pork1977gm how are you?

Just purchased this addon and for the life of me I can not get the converter to work properly and my videos to work on iPhones :frowning:

Do you by chance have a tutorial on this?

Hi @pattokane,

I’m good thanks.
Which action are you using? I didn’t demo all of the functionality but have you checked this page?

https://paul-testing-4.bubbleapps.io/version-test/tools

Just let me know the details on the action, screenshot etc and I’ll do my best to help you get it working.

The demo pages I’ve done should all be accessible from the Red buttons on the main demo page (which is a little messy at the moment).

image

So I can record the video and it works fine but as soon as it’s on an Apple product, it breaks.

I have an app where trainers give video feedback to clients and have tried to set it up where it converts automatically to something that works on all devices.



I have tried so many variations like media_type’s URL, just the URL, the saved database URL and everything but nothing seems to work on Apple products.

Making me very angry lol I hate Apple products lol

I feel your frustration with this because I’ve run into the same problem and it was the main thing that led me to put some sort of “convert video” action into the plugin, even though it uses cloud convert to do it. I initially wanted to do with ffmpeg client side, and for a while this worked until about 6 months ago, all browsers released an update which made it no longer work. But yeh, Apple are damn annoying when it comes to media playback!

So, if you use the recorder to record a video on an APple device, it will play back on an apple device since the codecs used in Safari are all apple and it just works. If you record a video on something like Chrome or Edge, then it might play back but then it may not. Apple iOS15 made some improvements to media playback and I started seeing this working so first make sure you’re using the latest version of the plugin AND you have iOS15 then let me know how that works.

I take it the video convert action is actually working? you can see the new mp4 in your bubble storage area right?

I can run some tests for you to try and help.

1 Like

I am not sure if the convert works as it sends through and works on my Android but then does not work on iPhone, so I think it is working as I can view it but I am not sure lol

I have tried it on a couple of different apple products and they all say this video can not be played ad it is the wrong format

Ok, so first check to see whether the “myVideo.mp4” file is being created in your storage area after the action has run. You have the wait option set to Yes also I see which means that action will wait until the file has been converted before moving onto the next action in your workflow (step 3). This might be good for smaller videos as they can convert relatively quickly but it might not be so good for larger files, in which case you’ll want to set up a backend workflow to capture the response from Cloud Convert that they send after the conversion has been done. I wouldn’t worry about doing that for the time being, try and get the URL for a converted video first, pop it into a state and have the state show on the page so you can see it, then send that URL to me and I’ll try it on my iPhone also which has the latest iOS installed.

If you’re really struggling with this, I can help you out over a Google Meet later in the week if you’d prefer, if I get some time free.

1 Like

I’ll give this a try man after the gym and get back to you.

Thank you for helping me out, I am sort of new at this lol

Do I need cloud convert for this to work properly?

The action uses a free api key if that field is left empty, but it only has 25 mins of free conversion time everyday. I would recommend you use your own one so you don’t run into problems. We should be able to get this working without conversion though, that’s what I hope anyway.

I’ll work on getting I working with the free one and then upgrade once it’s done