Forum Academy Marketplace Showcase Pricing Features

[Plugin] WalletConnect by EzCode

Hi, everything is perfect, already working, got the connection for desktop and mobile completed.

1 Like

Question:

I have both web3 metamask and walletconnect, as far as logging in they work perfectly. I am trying to implement a get nft metadata function where users would have to have an nft to enter. This function works on desktop but does not work on mobile.

For desktop i am using web3 metamask plugin to connect
For mobile i am using walletconnect plugin

NFT metadata is a part of the web3 metamask plugin, could it be thats the reason its not working for mobile as i am using wallet connect for it?

Yes, that’s exactly the reason. The Metamask plugin will work if it is connected.
I will add the get NFT metadata for walletconenct as-well. :wink:

1 Like

excellent, thank you, that would be great

Another question:

Capture

I receive this message when using mobile. It only happens during the first login when the wallet is not connected.

Steps that happen

  1. I click to login using wallet which triggers connect wallet function
  2. I press connect in my wallet
  3. It takes me back to login screen and throws out this message
  4. I press login using wallet again which triggers signature
  5. I sign and login

How can i avoid this error being shown?

It depends on your workflow, I suppose you are trying to sign a message right after click connect.
Make sure to set this step in the connected workflow, additionally you could add a conditional, only when wallet is connected is yes

Update v.1.7

New feature:

  • Get NFT Metadata
  • Event: NFT Metadata is Ready
  • State: NFT Metadata (the result is a text in JSON string format)

In the workflow i have

  1. Custom - Connect wallet - Connect wallet walletconnect A
  2. When - WalletConnect A Wallet Connected - Sign WalletConnect A

tried adding “only when” still the same thing

That was fast, thank you

is it possible for you to remove the error for signing? that way no error would pop up and the users would simply click connect wallet again and sign. Would seem as if there was no error to begin with

Try to add a small pause before running the Sign action, like 200-300 milliseconds

sorry, how to add pause? and would it be in “only when” section?

Bubble action called “Add a pause before next action” it should be right before sign action

1 Like

thanks, that works. Honestly, thank you, not many plugin developers actually help out and reply so quick on top of that.

1 Like

2 questions
do you have a plugin for encrypting messages?

looking at your web3 manager plugin, want to implement a reward system on my webapp where users claim rewards based on their activity within the app. So if a user was to receive 10 likes on his post he would have 10usdt to claim. Would web3 manager be able to get this done?

Sorry for messaging so much today, trying to finish up on my day off.
If i understand correctly, once i sign a message it gives the message a tx? If yes, where would i enter the tx to find the message content?

When signing a message, you receive the signature, you then can save this signature somewhere.
This is used to proof the wallet ownership. You can then use the action “Verify signature” it will give you the wallet address as the result, if this is the same as the one that signed it initially, then the it is the proof of the wallet ownership.

There’s a video of how it can be used as a password for account creation in database here.

1 Like

Hello @ezdev,
I am trying to get balance of a token that isn’t on chain ID 1 but i cannot seem to figure out how to change chain ID even though my mobile wallet isn’t on chain ID 1, for instance on crypto.com app i can’t get the balance of the native token.
Looking forward to your reply !

Important Update v.1.8

Great news!

Infura ID is no longer required!

This parameter was removed from the plugin settings.

@louislherrou update to this version, it will solve your issue.

Great update it works when I change chain on metamask but it doesn’t recognise the chain on my crypto.com app as it says chain ID 1