Forum Academy Marketplace Showcase Pricing Features

Problem getting dev data into live database

After deploying my site I wanted to copy the test data that was in the dev database into the live database.

Maybe there is an easier way to do this, but as I don’t know what that is, I figured I’d just export the dev data and import into the live database.

Everything went well until it got to a list field and I got a message about choosing a delimiter. I tried everything that was on offer, but still kept getting this error:

As the data is coming out of Bubble and back into Bubble I don’t get how it would be in the wrong format.

So, couple of questions:

  1. Is there an easier way to just switch dev data into live data?

  2. Why am I getting that error and how do I get around it?

Thanks for your help with this.

Hi @Siddhartha,

Yes, there’s a much easier way to do this :slight_smile:

Go into the Data Tab, and App Data. Then find the red link that says Copy and restore database. There, you’ll find ways to sync the database both ways.

4 Likes

LOL! Am I now glad I asked that first question :slight_smile:

That was sooooooo much easier.

Massive thanks for saving me so much time and messing around.

1 Like

It’s supposed to be the same format. Maybe send a bug report?

1 Like

I totally agree @JohnMark. That’s what I was expecting.

Luckily @petter came up with a super-easy alternative, which is way simpler and saves me having to export/import :slight_smile:

1 Like

Can you mark this topic as solved. Saves me clicking :smiley:

Sure thing. Sorry about that.

You are forgiven

1 Like