Problems with Google Calendar + Offline

Hi everyone. I’m using the Google Calendar + Offline plugin to connect our coaches’ calendars to their portal. Up until last week, it was working just fine. This week, I started having the following issue:

It’s supposed to show this screen when the user’s Google Calendar is not connected. Specifically, the rules is that if the current user’s Google Calendar Offline Email is unknown, show first element. If it’s known, show second element.

Screen Shot 2020-05-14 at 1.14.23 PM100% • 75% • 50%

It’s supposed to show this repeating group when the calendar is connected ("current user’s google calendar offline email is known) :
Screen Shot 2020-05-14 at 1.14.39 PM100% • 75% • 50%

I’m seeing this instead:
Screen Shot 2020-05-14 at 1.15.21 PM100% • 75% • 50%

Through a bit of troubleshooting, I’ve discovered a few things:

  • When I try to re-authorize my Google calendar, I see this pop-up:
    Screen Shot 2020-05-14 at 1.22.24 PM100% • 75% • 50%

*When I try to print the “Current User’s Google Offline Calendar Email” as text, nothing shows up.
Screen Shot 2020-05-14 at 1.23.17 PM100% • 75% • 50%

I should see this printed:
Screen Shot 2020-05-14 at 1.24.50 PM100% • 75% • 50%

Instead I’m seeing this:
Screen Shot 2020-05-14 at 1.25.02 PM100% • 75% • 50%

When I add the rule below, I still get the empty text, indicating that there is an email attached, I just can’t see what it is.

Screen Shot 2020-05-14 at 1.49.13 PM100% • 75% • 50%

My takeaways:
-It seems like the user is connected to an account BUT
-for some reason I can’t access it.

Any thoughts for continued troubleshooting? Like I said, this was working fine before and suddenly stopped without me changing anything. It’s similarly broken for a new account (i.e., one that doesn’t have a gcal connection) and old accounts.

1 Like

I’ve installed it today and am having exactly the same type of issues

it’s connected but as soon as I look for information about the User’s Google Calendar Offline’s email, the element dissapears.

@levon is there something we’re doing wrong ?

hi @dee
thanks for pinging me, because I haven’t seen @maryfox20’s original post
i’ll ask the team now to check this out and get back asap
Thanks!

Hi guys, @dee, @maryfox20,

As we see, it has already been requested in this thread here https://forum.zeroqode.com/t/problems-with-google-calendar-offline/3302. It might be an issue coming from Google. Could you please check on it and try to follow the instructions. However, if you experience the same or any other issues, let us know.

Best regards,
Zeroqode Team

Thank you @levon. I’ve emptied the cache, created new credentials, and even uninstalled and reinstalled the plugin.

The problem is still there and I have a new one in that the “Current User’s Google Calendar Offline” option has disappeared.

I could initially get the info through “Get info from API”, but that’s gone too now.



I’ve tested this on both Safari and Chrome and have the same issue.

so… I tried uninstalling and reinstalling the plug in and… the option "current user’s google calendar offiline is back.
Capture d’écran 2020-05-21 à 10.47.20

In Editor

But still not showing up on the app side.

And 2 minutes later… the option “Current User’s Google Calendar Offline” has gone again.

Help!

Hi guys @dee, @maryfox20,

It seems to be a plugin issue. This behavior is reproducing among some other plugins as well, which relate to Google authentication. Please let us fix it and we’ll notify you back asap.

Thank you in advance for understanding. :pray:

1 Like

awesome. Thank you @levon

Hi guys @maryfox20, @dee, we have fixed the plugin. Please upgrade to the latest version, refresh your app and give it a try again.

However, there are a couple of things to mention regarding data display.

This way of display/setting condition for user’s email is not correct:

image

Because, when you signup/login with provider as Google account, the email of the current user is automatically detected as your Google email. You can simply display Current User’s email:

image

It also refers to any other place within your app where you display this data.

Thank you for your patience. :pray:

1 Like

Thank you so much for your fast fix and for the details!

That might be a reason for some of the issues I’m experiencing. Because I didn’t use OAuth for sign in, but just to connect to a calendar. The user already exists and has a different email. Could that be the reason it’s not working properly?

Hi @dee, thanks for your feedback.

Yes, it is required to signup/login with provider as your Google account based on this plugin, of course. Otherwise, it would be impossible to connect to the calendar. So, when you are connected, if you want to display user’s email, you just do it by Current User’s email and it will understand the proper account.

Thank you!

Final Update — When I logged out and created a button to log in using the gcal plugin, everything worked smoothly. I think I can make this work but it would stsill be great to be able to disconnect a gcal account from an app user (and give them the option to use their email instead).

@levon
Thanks for your diligence here. It’s still not working for me.

The first problem is that it’s not true that it’s the “users email” (rather than google calendar offline email) as you mentioned before, because in our case the existing user created their account using an email address (maybe months ago) and now wants to connect their gcal. They can authorize the same email or authorize a different email — Meaning that there could be two different email addresses in play. And indeed there are, which is why I’m running into this problem in the first place.

I think if I could disconnect the account and reconnect, that would help —would it be possible to add this feature? (disconnect a gcal auth from an existing bubble user?).

I’m still getting the error that says I can’t authorize my gcal account becuase the “email is already being used”…but the email is being used on this same account that I’m trying to auth. The user email is (for example) mary@domain.com and the gcal is mary2@domain.com. I’ve connected them with no problem in the past but now gcal hates me. :wink:

Update — I also changed my email address to be the same as the gcal (just in case) and i’m still getting the above error message.

Update — With the new email connected (i.e. same user email las the gcal email), I’m not getting a 401 error when I try to interact with the calendar. When I go to reauthorize, I get the the same error re: “already an account for this email”.

Hi @maryfox20,

Thank you for your feedback and updates. It is actually an interesting use case. Please let us check on it, so we could provide a better feedback on this matter asap.

Best regards,
Zeroqode Team

Hi @maryfox20,

This might not be true for this specific use case, however, it is true that if you signup/login with your gcal account as provider, you can simply display Current User’s email and it will show you the gcal email.

There would be two different email addresses, indeed.

This error will pop-up, indeed. Because it is trying to double authorize, as you might have already authorized with an account.

It would be best to use the separate authorization with gcal account as provider, so it will make things work properly.

It is possible to disconnect even the gcal account, by simply logging out the user. You can check how it’s done in our demo app here https://zeroqode-demo-11.bubbleapps.io/google-calendar.

However, we’ve taken into account your feedback and will look into future possibility of improvements.

Thank you for understanding.

Best regards,
Zeroqode Team

Thanks, I’ll take a look. I appreciate your reply.

1 Like

Hi @maryfox20,

We are glad it was helpful. Just reaching out to ask, if you like our plugin so far, could you please rate it by going to Plugins tab in Bubble editor. You can find the plugin by name and give it as many stars as it deserves. The more feedback we get, the more motivated we are to build great plugins!

Thanks :pray:

Hello again, @levon — I’m running into a challenge “watching” events. IT seems that I would need to do a post for “watch” events and then that would send back my “channel ID” that I would then use to watch calendar events. Do you have any additional resources on how to set this up? Right now, our biggest challenge is that the calendar doesn’t update in real-time when someone declines or accepts an event. Thanks!

Hi @maryfox20
you would need to use this पुश नोटिफ़िकेशन  |  Google Calendar  |  Google for Developers
i think our plugin has calls to set these push notifications, but then you should also set up API workflow endpoints in your Bubble app to be able to receive updates from Calendar webhooks and to perform any data actions based on those.
Please check the manual or this forum on how to use API workflows in Bubble
Hope this helps
Thanks!

Levon Terteryan

Founder @ Zeroqode

zeroqode-for-web-160x120

Bubble Templates

Zeroqode Blocks

Bubble Plugins

Bubble Courses

Convert Web to iOS & Android

No-code Development Services

At this time, it’s still not very fluid when it comes to letting existing users sign in with their calendar. We’re having a lot of problems. I wouldn’t be able to use this externally yet.

@maryfox20 Apologies, but it’s quite difficult to locate a root cause of a problem with the small amount of details on it.

If you provide us with some more details that can help us understand what causes your issue, we will be able to investigate your case more efficiently. Would you kindly supply the step by step script how we can reproduce the error and screenshots of your settings.

Thank you for your patience.

Regards,
Zeroqode Team

Hello @maryfox20

I was wondering what you did to solve this, since I believe I have the same problem as you. My users are emplyers of my company and the email address used to sign in is the company email. When I try to connect the google calendar I get the same errors as you. I am not sure I can connect to calendar since I always get the same invalid credentials error. Perhaps you could help me.
thanks in advance