Properties.action array formatting failure

Hi Guys and Gals,
I have been racking my head around this one for a few days. Maybe im missing something extremely simple.

Steps:

  1. I have latitude, longitude in my table.
    Table is text.

  2. I merge many of these into a separate table to create my array of lat/longs (ignore the missing comma)
    Table is Text

  3. I then grab these into my plugin

  4. For my plugin im using turf.js. This is what it requires

  5. This is how I built it

  6. I did a very simple test, with hardcoded lat, long values

Works beautifully

The problem starts here:
7. I replace the hardcode with properties.lat_long which is the array from the DB table above

It fails: I get a failure message from turf.js stating that it must be an array

  1. I console log properties.lat_long to see what its sending before & after the call is made

These are the results: Looks like an array to me…

  1. I copy the console values and hardcode them in

Works beautifully

I have tried multiple things to get properties.lat_long to work.
split()
Stringify
Parsing
and many other things and at this point I need someone elses guidance in teaching me what I am not seeing.

Cheers! :beers:

1 Like

Hey Dortiz,

I cannot help you solve this, but I wanted to ask if you got this solved and if you’re going to offer your Plugin for purchase/public use? I’m looking to do point_in_polygon searches for our app and would love to not duplicate efforts.

Thanks in advance for the consideration,

Bryan

Hi bryan3,
for this, there 2 options in my mind :

With Leafy there this option :
image

And with geofence :
image

At the moment, i’m using the geofence one in order to limit the potential user of my application to my city.

DM me if you need more informations.

2 Likes