Forum Academy Marketplace Showcase Pricing Features

Random ID delete entry

Hello everyone,

I made a random ID to identify entries on my database but i don’t know how to delete the thing which contains it.
All I want to do is searching an ID and delete the thing which contains it. I tried by myself but it didn’t worked.

I tried this: button clicked-> Delete thing…-> To delete: Do a search for (due to I can’t choose the field which I looking for)-> Type: Thing I want to delete (Here I tried with contrains but it didn’t work neither) → (we go to the menu at the right, where I tried a lot of options) (More…): :each item’s ID → :contains → ID Input’s value (I tried :formatted as Number too and it didn’t work).

After all of that it keeps with (More…) and red. When we talk about Database, ID Field is a Number and ID Input Text (I tried Integer too).

Could you help me please? I’m really thankfull.

Hi there, @juanmanuelvillarmouc… it is unlikely that anyone will be able to help without being able to see what’s going on, so you should consider sharing some screenshots. That being said, it should be as simple as doing a search for the thing to delete and adding a constraint to the search that looks for the ID in question. At that point, remember to add the :first item operator to the end of the search expression, and you should be good to go.

If the search doesn’t work, you might want to check to see if any privacy rules are getting in the way. Also, check the debugger when you run the workflow to see if you can get any clues as to why the search isn’t working.

Hope this helps.

Best…
Mike

First of all I have to thank you about your answer.
oh, sorry! I am going to share some screenshots. I think I have made what you said @mikeloc but it keep doesn’t working.
Captura de pantalla 2022-05-12 081213

The field that I search pressing the button is a Input where I show the ID operation but I see that It doesn’t work like an input (I tried with “This input is disabled” cheked and unchecked but nothing to report)
Captura de pantalla 2022-05-12 081459
(Field ID in database is Text too)
When I press the button and run step by step:

How can I fix it?
Thank you again!

I don’t understand what you mean there, and I don’t understand why you have an input that has a search expression as its placeholder. Is the user supposed to enter an ID in that input? Or is the input supposed to be populated automatically with the result of the search expression? If the latter is what you want, try moving the expression from the Placeholder field to the Initial content field and see if that helps.

What I want to do is:
I made the app works and saves an entry with an ID. Now I want to be able to delete it, for example, if I type wrong. My first option was using “:last item” but app could be working simultaneously with more than one user and someone could delete an entry of another, that’s why I need an ID. To sum up, I want an “undo” button :slight_smile:
Why do I use an Input? Because I don’t know how to introduce in the app an ID without it (an Input field), I tried but i wasn’t able to do it. And no, user could not enter an ID
I’m new in this platform so I don’t understand how It works. Sorry

You shouldn’t need to create a random ID for something like that. If I understand correctly, a user is creating a thing in the Caja data type, and you want the user to be able to undo the creation of the last thing they created (or in other words, delete that thing), right? If that is correct, it sounds like the expression for the thing to delete could/should be Search for Cajas:last item with a constraint on the search of Created by = Current User.

Ok. It worked! Thank you! :heart_eyes:

1 Like