Register User As Seller Not Working

Hi guys! I’m trying to use the register seller action on my app but when I click a button to trigger the action the app simply loads without anything appearing.

I have added all of the client, publishable and secret keys to my app and tried using both and in my Stripe Account as the redirect URLs without success.

I was able to sucessfully create a test charge in my app.

Not sure exactly what the issue could be here. Has anyone had a similar problem?

Any help would be greatly appreciated.

Thanks guys!

Hi @evanlitttle,

The “poststripeauth” one is the url you need there, so that’s #1.

Next, are all your keys split up by test and live? You have two sets, one for each environment. There’s a toggle in Stripe’s dashboard (lower-ish left) so that you can access the different keys.

Make sure you’re logged in as a user in the Bubble app when you run the “Register” action.

If things still aren’t happening, maybe you can post your editor link and I can take a look at it.

Gaby at Coaching No Code Apps (formerly Coaching Bubble)

Courses & Products, Tutorials, Private Coaching, and High-level Development

Start Learning Today :mortar_board:

thanks for the tip on the " poststripeauth"! I do have my keys split up by test and live. I’m setting up the stripe.js plugin right now instead of using Bubble’s Stripe plugin so I can have a more user- friendly seller onboarding process. Hopefully I won’t experience any similar issues

Bumping this up. I’ve set up all according to @romanmg instructions and I’m getting the endless loading bar at the top, and no account created. Everything is set up in Stripe with the correct URI and the keys.

Any idea?


Check out the browser’s console. Perhaps there are some errors.

BTW, I had the same issue in the past. It was resolved without any effort from my side :slight_smile:

As a solution, you can open a bug report.

Did you ever figure this out?
I have endless loading bar too?

No, we ended up working with CoPilot to fix. Think they have updated their plugin now

Ok thank you.


I’d like to bring up this issue since it seems that “Register User As Seller” is still not working.
I did everything as described but get an endless loading bar.

I checked the browser console and found that there is a JavaScript error as soon as the workflow is triggered.

Did someone actually get this running?

I had the same problem in November last year. Recently I tried going through with a test account and it seemed to work.

Hi @tim4 can you please elaborate a little bit. it looks it is a problem for everyone.

I was running into this issue as well. After initiating the “Register the user as a seller” workflow, the loading bar would start creeping and timeout. After looking in the browser console, I notices a peculiar Google Maps API error when I started the workflow.

Essentially, My stripe seller registration flow was getting stalled by a Google Maps API error.
The error was related to by referrer domains not have “*” on the end of them in my Google Cloud Console.

Once I fixed that I was able to run the Stripe flow.