Forum Academy Marketplace Showcase Pricing Features

Repeating group - add template lists

I am making a project management software app -Part of it uses a similar set up to Trello, with a board, lists with customisable names and task cards that can be dragged and dropped within it.

I currently have it set up so that when a user creates a new board the page is empty and a user can add as many custom named lists as they want.

I would like to add some initial structure to the board/lists. Is there a way to include multiple lists that appear on the page as it loads (like a template), but users still have the option to add new lists too. I would like users to have a set list structure initially (like a template) but still have the flexibility to customise it as well.

The lists are currently set up with a repeating group, and the tasks are another repeating group within the larger one.

Any help would be hugely appreciated :slight_smile:

Probably the easiest thing to do is to adjust the workflow which is used to create a board, to include a step for creation of a list. Another option would be to create one or more template lists and using the workflow step “Copy a list of things…” and “Make changes to a list of things” assign those template list(s) to the new board everytime one is created.

1 Like

Hi Gerbert - this was helpful but I am still a little stuck. I was wondering if you could help me at all. I have tried your first option and I can see from my app data that it is successfully creating a new list in the database. My issue now is that it isn’t displaying on when I open the board page.

At first I thought it was due to my privacy settings but I have linked it up so it has the organisation space and board id (I am making a SaaS piece of software), so the privacy rules should be fine.

Any suggestions for how I get it to display?

This is my set up for creating a new list

My second challenge is that this appears to only allow me to create one list at a time, and I would ideally like to have multiple appear at once.

Do let me know if this doesn’t make sense or you need more context. Thank you in advance!

Hi Kathryn,

Perfect, yes sure. If the new list is not being displayed, it must be that one of the search constraints or indeed a privacy rule is filtering data. Removing the search constraints one by one until you see the data is often the easiest thing to do. If that does not solve the problem, make adjustments to the privacy rules.

About you screenshot, if a list is attached to a board probably you do not need to also attached it to an organisation-space since the board already has this field.

About your second challenge, indeed that only works one by one (just use one workflow with multiple steps). Or it might be an option to create a couple of “template” lists manually:

  1. Add a field template yes/no to the type list and manually create these lists with field template = yes.

  1. After that you can use workflow action Copy a list of things" to select and copy those lists:

  1. Next use workflow step “Make changes to a list of things” to assign them to the newly created board:

Let me know if it works, if it doesn’t and you are really stuck, we can also have a Google Meet if you want.

1 Like

Amazing thank you - I am going to play around with the options now. I will let you know what I come up with. Thank you again!

Hi Gerbert, I just wanted to say it worked perfectly yesterday. I realised it was my search term that was preventing it from showing, so I have opted for your first suggestion. Thank you so much for you help!
Best Wishes,
Kathryn

This topic was automatically closed after 70 days. New replies are no longer allowed.