Forum Academy Marketplace Showcase Pricing Features

Repeating Group Not Showing Content

Hi Guys,

I can’t for the life of me get this to work. I have a repeating group displaying Businesses from a database.

The repeating group has a group within it to set styling of the group.

I have set the Repeating Group’s data type and source.


I have set the Container Group’s data type and source as below:

I have set the text to display as below:

On Preview mode nothing is displaying, not even the container group, which leads me to believe there is something in the container group’s setting of “Current Cell’s Business”.

Any advice welcome!

In RG, it’s like type A’s typeB’s item.
Two types sandwiched together cannot be displayed.

In this case
do search for business_type (Business contein current cell’s business)'s Display.

it will work.

Thanks makara. I am not sure I understand correctly. Should the RG be of type Business, and then the Container Group of a different type?

Oh, wasn’t RG a Business type?

Even if RG is a Business type, the elements inside can use do search for.

I’m doing something similar in this image.
Can i help you?
image

Even in this image, it’s really
“parent group’s students’ user’s icon”
but for the same reason, I’ve changed it to this

Okay thanks for your help. I am still not getting it right because if I Do A Search For in the Container Group, the result evaluates to a List of Businesses, and obviously for the container group you only want to display one Business, which is This Cell’s Business.

Oh! A miscommunication.

The photo I sent you was…
This is the edit screen of the image included in RG(data type student).
So you should mimic this with dynamic text!

Unfortunately still not working. I am fairly certain it is a disconnect between the RG and Container Group, because the Container Group styling is not even appearing in the preview.

I’ll try a simple example which might illustrate better.

Here I have a RG of type Businesses, which I want to display a list of businesses.
I have put dynamic text in each Group which should list the business name. Here’s how I have done it:

Repeating group:

Business name:

On preview, nothing is displaying:
Screenshot 2021-09-02 at 11.00.35

Am I doing something fundamentally wrong?

The only thing I can think of is that the data doesn’t exist…

I’m sorry I can’t help you after listening to all this.

1 Like

Could it be an error?
@bubble_development

Hi there, @simon.purdon… your setup looks okay to me.

Any chance you have any privacy rules in place on the Business data type that could be getting in the way?

Also, just for kicks, check the Ignore empty constraints checkbox in your first screenshot to see if that has any effect.

Best…
Mike

2 Likes

You nailed it. Such a dumb mistake. Thanks so much!

1 Like