Repeating Group to CSV Download - New Plugin from Zeroqode

Considering this plugin. I have a table with roughly 50 columns of data. Any combination of them can be shown or hidden). When they export the table, we only want to bring the visible information into the CSV. I need the export to check if the field is hidden from display or not.

I would like to know how about omitting columns from export.
Is it possible to dynamically set which columns are hidden?
Can this approach work for multiple hidden columns?

Hi @nocode123,

We’re sorry for the late reply on this matter :frowning:

This plugin should download only the visible information that the Repeating Group fetched.

Could you please provide more information about your use-case, some screenshots of how your app works, how you hide/show a column in the repeating group, how you set up the plugin, and any extra information that you think is important, in order to help us create the same environment to test this issue.

Thank you for your patience and understanding :hugs:

1 Like

Thank you! I was able to get a solution working using this plugin!

I am having some odd issues with it. The page is quite complex. I have roughly 50 columns and I use a text string stored as a list of texts to check if the column will be hidden. Then have conditional statements that show/hide the columns if they are in that string. Works visually perfect.

The trick is the export function seems to grab hidden columns at times.
As well, it is appending a , at the end of the captions (1st row) of the CSV export around the area that it starts exporting the hidden fields. So when the page is display, the column captions and columns go like this:

Column 1 | Column 2 | Column3* | Column4 | Column5

In this example above Column3* is hidden and would expect 4 total columns (Col 1,2,4,5) in the CSV export, but I am getting all 5. Also noting that after this happens, there is a comma at the end of Column4+5 which shows up in the CSV file when opened as “Column4,” and “Column5,”

It always is exporting a valid file, the columns, even when there are more than expected, show up with the correct values.

Any ideas why it might be grabbing hidden columns?
I have some set to hide on load and some to visible. Then conditionals show / hide them. Going to try normalizing the page. Even thought visually it is working, this seems like the better solution.

@nocode123 Thanks for the details.

From what you told us, the repeating group with all the columns gets rendered first, then hides the unwanted columns. The plugin sees all the data the Repeating Group loads first meaning that if you hide one or more columns after the repeating group loads, the plugin will still consider all the data that has been loaded, as data that needs to be downloaded.

We propose a suggestion for you to give it a try:

  1. On the first repeating group, let the users decide which columns they want to be hidden/ignored.
  2. Display the data that the user chose to see, in another repeating group, either in a popup or a different page (your decision on how you want to do it)
  3. Let the user download only the second repeating group, that has only the columns they require. This way, the second repeating group has only the data that needs to be downloaded and nothing else.

In a nutshell, there should be 2 RGs. One where the users can select the data they want to hide/show and another one that they download where the only data is the user’s choice.

Give it a try and see how it works on your end

Cheers :hugs:
Zeroqode Support Team

Hey there

Love this plugin - really helpful

I am trying to create row gaps in the download … is there an easy way to do this?

EXAMPLE:

1st row should be completely blank
2nd row should have ‘titles’
3rd row (and onward) should be ‘rg’

Would love some help on this …

Thanks so much

Hello @dhalpern6,
Thank you for your message.

We will check with the team and get back to you as soon as possible.
Thank you for understanding.

Cheers!

Hello @dhalpern6,
Thanks for reaching out!

To help you better, we need a bit more detail. If you can, please send us a short video of what you’re doing. You can use tools like Loom or any software you like. Also, can you show us, what you want your table to look like after downloading?
Please include any other important information you believe would help us identify the source of the problem.

Cheers!

Hey there, everyone!

Exciting news! We’ve rolled out another update for the plugin, and this time we’ve introduced the XLSX option for the RG to CSV element. That means you can now create XLS files from your Repeating Group too. :slightly_smiling_face:

To check out this new feature, simply update your plugin to the latest version (1.44.0) and refresh your editor.

Demo: https://zeroqode-demo-05.bubbleapps.io/rg-to-csv

Hope you enjoy it. :pray:

Regards,
Zeroqode Support Team

1 Like

I can’t get the URL thing happening. I’ve managed to add a download button which works well . The idea is that i want the users to have access to the CSV file. The button option crashes the app version (building it using bdk). Is there a way to have the download link e-mailed or somehow get the link working so it opens within the app or opens another app (i.e excel?). i tried sending an e-mail and in the body i put rg*** URL for download but it doesn’t work.

Hello @klevis,

Thank you for reaching out to us!

As we are building our plugins web first, unfortunately, we can not guarantee the functionality of the plugin if the app was wrapped by a third party software. We are sorry for the inconvenience :pray:

We’ve tested the plugin to provide you with the most accurate information. If you enable the option “Save to file manager” and disable the “downloading the file” option inside the download action, the plugin’s element state called “URL for downloading” will be populated with the URL of the file.

Please double-check your settings to ensure that the state is being populated this way.

You can use this URL in conjunction with an email plugin to send the URLs to users. Alternatively, you could utilize the Air Document Viewer plugin. By placing the element on your page and adding the URL of the file, it should display the file within your Bubble app.

Wishing you a productive Monday! :hugs:

hello,
In the downloaded csv file, headers or captions ends with a ", " instead of a return.
image

resulting in

Is there a way to fix this?
Thanks

Hello @yasirzxc,

Thank you for reaching out to us.

Based on your message and the attached image, it appears you are referencing the “Separator” option from the action[image]. This allows you to change the separator from a comma (“,”) to a space or any other character.

Could you please give this a try and let us know if it resolves your inquiry? If not, could you provide more details about where exactly you’re seeing these commas as presented in your image?

Thank you again, and we look forward to your response.

Best regards,
Zeroqode Support Team

1 Like

Hello @ZeroqodeSupport,

Thanks for the response, I tried removing the comma from separator field, but it resulted in a CSV with no commas throughout.

image

Let me elaborate
My End result in bubble is

Workflow

CSV download

where my required csv would be like this

As in after the captions (headings) there should be no seprator like other rows.

Thanks.

1 Like

Hello @yasirzxc,

Thank you for your message and for providing the details. :pray:

After reviewing your information, it appears that you haven’t checked the “Enable caption (headers)” checkbox in the element[image], which is necessary for the CSV to include the header you have set.

Based on your use-case, you can visit this test page where we’ve prepared a small example to show you how it’s set up.

Could you please try this on your end and let us know if everything works as expected?

Thank you, and we look forward to your reply.

Best regards,
Zeroqode Support Team

Hello @ZeroqodeSupport,

I have 1 more plugin from zero-code and I was super happy with the support, hence I bought this one. Your team is doing an excellent job—kudos to everyone for the outstanding support and development.

Although my issue persists, it’s not a major problem and can be fixed manually for now.

Warm regards,
Yasir Ali

1 Like

Hello @yasirzxc,

Thank you for your message and kind words.

We’re so glad to hear that our plugins and support have been helpful for your projects, it’s always our pleasure. :blush:

Regarding the issue with Rg to CSV, you mentioned that it persists. Could you please provide more details on how exactly the issue persists? After checking it, the CSV appears the way you anticipated previously[image].

One important note: if you want to open the CSV correctly in Microsoft Excel, you should use a semicolon (“;”) instead of a comma as the separator in the action field. Excel uses a semicolon as the default separator, but you can change this if needed.

Thank you once again, and we look forward to your reply. :pray:

Best regards,
Zeroqode Support Team