Reset Password Email (w/Postmark) — Not Working

It seems like this topic has been covered heavily, I’ve went through all of them and was not able to solve this issue with Postmark and received the error “This is not a valid password reset request.” When I use Bubble’s basic email template, everything works fine so I’m lost on where’s the disconnect here.

I created a backend API workflow:

and then executed the proper steps:


When the user clicks on Forgot Password, a pop-up appears and asks for them to enter an email address. Once the user clicks on send, this workflow happens:

The receives the email, but I’ve noticed that a new token is not generating so they received this message:

Any help here would be appreciated :slight_smile:

I designed my own email template and I hope the HTML isn’t causing any issues.

I’ve got Postmark password reset working before. Any particular reason your password reset email is being sent in an API workflow? Could that be causing the issue?

@mattblake I tried sending it just through a normal workflow and got the same results, so I thought a backend API workflow could fix it — nope, same issue :grin:

Any direction here would be appreciated. I spent some hours on this and no results.

Can you check that the token is the same when generated in the workflow compared to the JSON Postmark received in the Postmark dashboard, checked again against the link once you’ve received the email? I’d check they are all the same.

Another thing I’d check is whether you have link tracking turned on as this will cause Postmark to change the link to a forwarder so they can check it for activity. Can’t say for sure if this is causing the issue but I’d check it.

I’d also consider using a Postmark template as I’m not sure how well all that html is sent via the API. You should be able to check the code’s integrity in the Postmark dashboard.

@mattblake sooooo the token is different from the JSON Postmark received.

On the Postmark dashboard the token is:
3D1657059444627x556=698002541185600

Clicking on the email link, the token is:
1657059444627x556698002541185600

Also, I have already disabled link/open tracking on this particular email workflow:

Hey @saviorabrams,

This is my link setup if it’s helpful:

This topic was automatically closed after 70 days. New replies are no longer allowed.