Forum Academy Marketplace Showcase Pricing Features

Responsive Drag/Drop

Can someone point me in a direction of an example or guide to a drag and drop (with repeating group) solution that I can use with the new responsive engine?

Thanks!

1 Like

Hi there @care1,

I don’t think that it’s compatible with the new responsive engine yet. It’s on their radar of things to polish out with the new responsive engine.

Perhaps @nickc might have an update on that?

Nick followed up here:

2 Likes

Cool! Didn’t see that- thanks @doublejay

1 Like

Hi everyone! Bug fix for this went out yesterday afternoon. Let me know if your draggable elements are still misbehaving. Thanks!

2 Likes

I see the team doing some changes and updates to the Draggable Elements. Any chance the plugin can get version dropdown like normal plugins?

It would be useful to know when a new update has been issued.

4 Likes

Unfortunately, there is no versioning built into our hardcoded plugins (Draggable Elements is a hardcoded plugin). We are definitely aware of this limitation though so once we have the bandwidth to prioritize our bubble-built plugins, versioning will be a top consideration. Wish I had a better answer :confused:

2 Likes

Occasionally when I “drop” and item it doesn’t fire the workflow and it keeps the element that was hovered in it’s conditional hovered state (I have a border appear when it’s over a drop area.

Because of this, the border stays visible and the workflow isn’t executed. I could really use some help on what may be causing this and if others have experienced something similar.

Hi @nickc - Is it on your radar that the drag/drop element appears to lose reference to its parent when it is being dragged and that the responsive resizing of the drag/drop element while being dragged cannot be controlled to match its non-drag size? I’ve experimented with setting the min and max widths at percentages, but it doesn’t work.

This was not, but thanks for flagging. This plugin (as do a few others) needs a lot of work so I hope we can prioritize some bandwidth towards this in the coming months - but we’ll see. Will keep the thread updated.

1 Like

I hope this helps others. I’m still not sure exactly what’s causing the “when dragged and dropped” workflow to not fire occasionally, but I discovered it only happens when the draggable and droppable components are made using the new responsive engine. I made a reusable element which runs on the old responsive engine (otherwise identical), and placed it in my page (which runs on the new responsive engine) and it works fine. I’ll place in forum > bugs since Bubble makes this plugin.