Save Addresses and Display Them On A Map

Hello,

Not 100% sure its a bug. But I followed the tutorial for this exactly as it reads (from the learning center). When I get to the final options, which should be “Map Type/Map Style” and it says to change the “Map Style”, it doesn’t even come up as an option.

I’ve done it 4 times and reached out for some help, but was rerouted to the forum for help. So, before I chalk it up as a “bug”, can anyone take a look and help?

http://thearchapp.com/version-test/provider_locations?debug_mode=true

Thank you,

Te-Ana

I checked your link and you haven’t activated Google Maps Javascript API for the api you’re using.
The following error message shows up in your console on your page:

Google Maps API error: ApiNotActivatedMapError https://developers.google.com/maps/documentation/javascript/error-messages#api-not-activated-map-error

Follow the following link to activate google maps for your api key
https://developers.google.com/maps/documentation/javascript/get-api-key

Thank you!

I did this yesterday and got the API key and added the API key where it said to add it on Bubble. I see that I needed to add the code and include my API key.

I have now added the code and it’s still not working.

The key has to be the key only, not the JS snippet ("<script async defer …"). It should look like

AIza........................

Hi,

Yeah, I added the key only when I found it yesterday and it still wasn’t working. I just added the JS snippet now (I will remove it).

Still not working.

I’m honestly not sure what is going on. I have tried everything I can think of. Removed and adding the key back, closed the browser, restarted the computer.

I’ve tried to check to see if it’s working on my Chromebook (I’m currently using my MacBook Air to work on the app).

Don’t know what else to do.

This message “ApiNotActivatedMapError” is coming from Google, so that means you need to fix something on Google end. Make sure the Javascript MAP API is activated, by default it’s not.

In any case, the error is returned by Google, not Bubble so it’s in their documentation (https://developers.google.com/maps/documentation/javascript/error-messages)

Ok.

The Google Javascript Map API says to add the entire code (ie. script tag).

I added it exactly as it says and it’s still not working.

I’ll reach out to Google for help.

You added the key correctly, but you need to turn the API on in Google’s dashboard.

1 Like

I turned it on.

It’s not working.

I’m going to close it out and retry.

That took a lot to find.

I am super new to technology and app developing so finding things and making the correct changes takes a bit. I am going to close the browser and see if it’s working now. I enabled the API on Google Dashboard and connected it to the right email address and added the API key to Bubble. I’m going to see if it works.

Thank you for all of your help!

Still not working.

I will reach out to Google for further assistance. However, I’ve done everything that you suggest and I appreciate you taking the time out to assist me.

Thank you,

Te-Ana

This topic was automatically closed after 14 days. New replies are no longer allowed.